[gnome-games] Created tag 3.37.1



The unsigned tag '3.37.1' was created.

Tagger: Alexander Mikhaylenko <alexm gnome org>
Date: 1587853013 +0500

    Version 3.37.1

Changes since the last tag '3.35.90':

Adwait Rawat (2):
      cover-loader: Cache icons
      search-provider: Support icons

Alexander Mikhaylenko (250):
      flatpak: Use add-extensions instead of --extension
      core: Remove MediaInfo
      options: Enable dualshock on the first port for pcsx_rearmed
      flatpak: Update pcsx_rearmed patch
      flatpak: Pin down pcsx-rearmed commit; drop the patch
      playstation: Don't set custom input capabilities
      gameinfo: Remove GameinfoDiscIdInputCapabilities
      retro-gamepad: Remove present_analog_sticks
      input-capabilities: Remove gamepad methods
      generic: Add GenericInputCapabilities
      libretro: Use GenericInputCapabilities
      ms-dos: Use GenericInputCapabilities
      media-set: Use icon name string instead of GIcon
      game: Add get_media_set()
      playstation: Use Game.set_media_set() instead of a separate cache
      Revert "flatpak: Ensure we use retro-gtk 0.18"
      meson: Bump retro-gtk API version
      retro: Adapt to API changes in retro-gtk
      retro-runner: Remove game-init and game-deinit signals
      tmp: flatpak: Use subprocess branch of retro-gtk
      error-display: Support showing crashes
      display-view: Handle runner crashes
      flatpak: Use opengl branch of retro-gtk
      retro-runner: Fix loading n64 savestates
      flatpak: Add ParaLLel N64 core
      Introduce Nintendo 64 plugin
      nintendo-64: Handle controller paks
      mame: Make extract-supported-games preprocess the file more
      mame: Regenerate supported-games
      mame: Simplify parsing
      meson: Reenable MAME plugin
      mame: Only define platform with application/zip mime type
      Revert Nintendo 64 and subprocess changes
      playstation: Only add games after they are complete
      media: Allow serializing with GVariant
      media-set: Serialize with GVariant
      core: Add GameModel
      core: Add PlatformModel
      ui: Use GameModel and PlatformModel for collection
      game-model: Ensure stable sorting
      database: Cache games
      database: Preload statements
      platforms-view: Ensure the first row is selected
      ui: Use filter func again
      game-icon-view: Subclass Gtk.FlowBoxChild
      collection-box: Fix indentation
      application: Only load collection after connecting signals
      collection-view: Ensure we the collection is shown
      collection-icon-view: Simplify add_game()
      platform-model: Sync with GameModel when creating
      main: Stop grilo from overriding options
      application: Handle command line file opening manually
      application: Add --search command line option
      application-window: Don't open games if a game is already opened
      application: Add --uid command line option
      Add search provider
      game-collection: Add load pausing back
      application: Ensure loading notification is shown after unpausing
      platforms-view: Fix selecting first visible row
      error-display: Support showing crashes
      display-view: Handle runner crashes
      display-box: Bind title to fullscreen header bar
      display-box: Bind can-fullscreen in xml
      Move HeaderBarWidget to ui/
      platform-register: Mark get_platform() return result as nullable
      database-game: Fallback to DummyPlatform if it's not known
      ci: Make unprivileged
      retro-runner: Simplify starting and savestate loading
      Fix AUTHORS and COPYING permissions
      flatpak: Make tests run
      flatpak: Remove expected test output
      tools: Add a script for running tests
      flatpak: Update core tests
      gamepad-mapping-builder: Add a comment explaining X/Y swap
      ui: Use clearer gamepad button names
      gamepad-mapping-builder: Use more ASCII art in the comment
      flatpak: Switch libevdev to meson
      gamepad-mapping-builder: Fix the comment
      display-header-bar: Hide menu and input switcher by default
      retro-runner: Reset metadata when starting without existing savestate
      ci: Clone recursively
      flatpak: Add shared-modules
      flatpak: Use lua from shared-modules
      flatpak: Build lua as the first module
      flatpak: Bundle SDL1
      flatpak: Replace dosbox with dosbox_svn
      build: Use libhandy master
      ui: Stop manually adding/removing folded style class
      preferences-window: Enable swipe gesture for leaflet
      preferences-window: Use extra boxes for subpage
      preferences-window: Don't call leaflets boxes
      preferences-window: Implement back swipe for subpages
      ui: Implement back swipe for collection subviews
      preferences-subpage-gamepad: Fix info message
      preferences-subpage-keyboard: Unify info message handling with gamepad page
      gamepad-view-configuration: Define namespace explicitly
      gamepad-view-configuration: Unify configuration for gamepad and keyboard
      gamepad-view: Use a hashtable for storing input data
      gamepad-view: Draw each button only once
      gamepad-view: Support drawing background elements
      gamepad-view-configuration: Rename inputs to buttons
      gamepad-view: Support analog sticks
      gamepad: Update gamepad svg and configuration
      gamepad-tester: Show analog stick position precisely
      gamepad-mapper: Animate analog sticks when mapping them
      dummy: Remove DummyGame
      database: Remove DatabaseGame
      Remove GenericGame and make Game a class
      desktop: Remove DesktopUid
      dreamcast: Remove DreamcastUid
      game-cube: Remove GameCubeUid
      libretro: Remove LibretroUid
      playstation: Remove PlayStationUid
      sega-saturn: Remove SegaSaturnUid
      steam: Remove SteamUid
      wii: Remove WiiUid
      fingerprint: Drop FingerprintUid
      dummy: Remove DummyUid
      Make Uid a class and remove GenericUid
      game-thumbnail: Remove uid
      uid: Don't throw errors for get_uid()
      retro-runner: Simplify construction
      retro-runner: Store game
      game: Make uid a property
      game: Make uri a property
      game: Make platform a property
      game: Make media set a property
      uid: Rename get_uid() to to_string()
      uid: Add Uid.hash()
      uid: Add Uid.equal()
      game-model: Move compare func to Game
      game: Use Platform.compare() instead of reinventing it
      platform-model: Use Platform.compare() instead of reinventing it
      uid: Add Uid.compare()
      display-view: Grab focus for CoreView immediately after focusing window
      retro-runner: Remove capture_current_state_pixbuf()
      savestate: Make prepare_empty_savestate_in_tmp() private
      display-view: Rename try_run_with_cancellable() to start_or_resume()
      display-view: Remove a redundant can_resume check
      display-view: Simplify starting the game
      retro-runner: Create display in construct block
      core: Add RunnerError
      runner: Throw errors from try_init_phase_one()
      retro-runner: Move get_unsupported_system_message() next to where it's used
      runner: Rename try_init_phase_one() to prepare()
      retro-runner: Merge init_phase_one() into prepare()
      retro-runner: Load savestate metadata in prepare()
      savestate: Pass Game to get_game_savestates()
      savestate: Add compare()
      savestate: Make load() public
      core: Introduce SnapshotManager
      retro-runner: Use SnapshotManager.get_savestates()
      savestate: Remove get_game_savestates()
      retro-runner: Move retro-specific snapshot creation to save_statestate_metadata()
      retro-runner: Rename save_savestate_metadata() to save_to_snapshot()
      retro-runner: Generalize save_screenshot_in_tmp()
      retro-runner: Move save_screenshot() to where it's used
      retro-runner: Merge store_save_ram_in_tmp() into save_to_snapshot()
      retro-runner: Remove an extra blank line
      retro-runner: Make create_savestate() not depend on tmp_live_savestate
      snapshot-manager: Move snapshot creation from RetroRunner
      retro-runner: Get rid of tmp_live_savestate
      savestate: Remove unused functions
      retro-runner: Move snapshot deletion to SnapshotManager
      retro-runner: Stop storing the list of snapshots
      retro-runner: Stop passing save dir around
      retro-runner: Don't duplicate core.get_can_access_state()
      savestate: Add missing license header
      retro-runner: Reset metadata when restarting
      retro-runner: Only reset metadata on start() when not ready
      display-view: Start the game even if resuming
      retro-runner: Call through to resume() in start()
      retro-runner: Don't instantiate in start()
      retro-core: Move instantiate_core() and prepare_core() to where they are used
      retro-runner: Have clearer names for is_initialized and ready
      retro-runner: Don't set booleans to false in construct
      retro-runner: Reset metadata when preparing, load save ram as part of it
      retro-runner: Remove save_ram_and_dir_set
      retro-runner: Do actual loading in load_savestate_metadata()
      runner: Throw an error in restart()
      retro-runner: Move on_video_filter_changed() to where it's used
      retro-runner: Merge instantiate_core() into prepare_core()
      retro-runner: Reorder functions to match Runner better
      retro-runner: Use newly created snapshot when restarting
      retro-runner: Make latest_savestate local
      retro-runner: Don't set running to false in prepare_core()
      retro-runner: Include pause() into deinit()
      retro-runner: Move deinit() to where it's used
      retro-runner: Explicitly pause/resume when restarting
      retro-runner: Rename reset_metadata() to reset_with_snapshot()
      retro-runner: Rename load_savestate_metadata() to load_from_snapshot()
      ui: Rename SavestateListBoxRow to SnapshotRow
      ui: Rename SavestatesList to SnapshotsList
      runner: Rename supports_savestates to supports_snapshots
      runner: Rename new_savestate_created() to snapshot_created()
      nintendo-ds: Rename NintendoDsSavestate to NintendoDsSnapshot
      core: Rename Savestate to Snapshot
      collection-header-bar: Use HdyViewSwitcherTitle
      game: Don't recalculate title every time
      application: Create .version file on new installs
      migrator: Bail if savestates dir already exists
      display-box: Don't hide cursor with opened popovers in windowed mode
      display-box: Fix the last commit
      retro-input-manager: Add controllers-changed signal
      retro-runner: Add controllers-changed signal
      flatpak: Add ParaLLel N64 core
      Introduce Nintendo 64 plugin
      nintendo-64: Handle controller paks
      nintendo-64: Fix player number in the pak switcher
      retro-runner: Fix media changing
      retro-runner: Don't try to stop core on error
      retro-runner: Don't use descriptor URI as media for standalone games
      retro-runner: Prefer gamepad over keyboard if both are available
      retro-simple-type: Remove Nintendo 64 string
      local-cover: Fix sibling spelling
      local-cover: Make the basename check more strict
      application-window: Propagate in on_window_state_event()
      display-view: Crash when the runner is null
      preferences-page-platforms-retro-row: Add a translator comment for "None"
      Stop translating exception messages
      main: Don't use "unowned var"
      shortcuts-window: Ensure GThemedIcon type
      collection-header-bar: Add .titlebar style class to headerbars
      display-header-bar: Switch to HdyHeaderBar
      display-header-bar: Add .titlebar style class to headerbars
      application-window: Switch to HdyApplicationWindow
      ui-view: Remove title_bar property
      collection-box: Merge into CollectionView
      collection-header-bar: Merge into CollectionView
      collection-view: Bind subview title directly
      ui: Introduce TitlebarBox
      fullscreen-box: Port to TitlebarBox
      display-box: Use the same headerbar in fullscreen and windowed
      display-box: Merge into DisplayView
      ui-view: Make a widget
      display-header-bar: Merge into DisplayView
      application-window: Create views in XML
      preferences-subpage: Use HdyHeaderBar
      preferences-subpage: Add allow-back property
      preferences-window: Separate selection mode and can-swipe-back
      preferences-subpage: Move headerbar within the window
      preferences-window: Port to HdyWindow
      preferences-subpage-keyboard: Simplify layout
      preferences-subpage-gamepad: Simplify layout
      collection-view: Allow back swipe in titlebar
      build: Pass --disable-since-check to valac
      game-thumbnail: Draw black background via css
      game-thumbnail: Simplify emblem drawing
      game-thumbnail: Always propagate drawing
      Version 3.37.1

Alexandre Franke (2):
      Update French translation
      Update French translation

Anders Jonsson (4):
      Update Swedish translation
      Update Swedish translation
      Update Swedish translation
      Update Swedish translation

Ask Hjorth Larsen (1):
      Updated Danish translation

Balázs Úr (3):
      Update Hungarian translation
      Update Hungarian translation
      Update Hungarian translation

Daniel Mustieles (6):
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation

Emin Tufan Çetin (1):
      Update Turkish translation

Goran Vidović (1):
      Update Croatian translation

Jiri Grönroos (1):
      Update Finnish translation

Kukuh Syafaat (5):
      Update Indonesian translation
      Update Indonesian translation
      Update Indonesian translation
      Update Indonesian translation
      Update Indonesian translation

Michael Scherer (1):
      Fix error message

Milo Casagrande (1):
      Update Italian translation

Nathan Follens (1):
      Update Dutch translation

Neville (15):
      Use display name instead of basename for user-facing strings Fixes #228
      application: Warn users of the absence of Tracker
      nintendo-ds: Added database file for overriding gaps
      media-set: Make get_media() public
      nintendo-ds: Set screen gap for top/bottom screen layout
      generic-input-capabilities: Add get_allow_gamepad_mode()
      input-capabilities: Add interface for get_allow_gamepad_mode()
      retro-runner: Ensure correct input mode when starting
      ms-dos: Disable gamepad input
      data: Remove application/x-desktop from desktop file MimeType
      ui: Add RestartDialog
      display-view: Recreate the runner when restarting
      runner: Remove restart()
      preferences-window: Correctly remove subpage with disabled animations
      flatpak: Pin down prboom commit

Piotr Drąg (12):
      Update POTFILES.in and POTFILES.skip
      Update POTFILES.in
      Update Polish translation
      Update Polish translation
      Update Polish translation
      Update POTFILES.in and POTFILES.skip
      Update POTFILES.skip
      Update POTFILES.in
      Update Polish translation
      Update POTFILES.in and POTFILES.skip
      Update Polish translation
      Update POTFILES.in and POTFILES.skip

Rafael Fontenelle (5):
      Update Brazilian Portuguese translation
      Update Brazilian Portuguese translation
      Update Brazilian Portuguese translation
      Update Brazilian Portuguese translation
      Update Brazilian Portuguese translation

Sabri Ünal (1):
      Update Turkish translation

Thibault Martin (1):
      Add translators comment to several translatable strings

Tim Sabsch (1):
      Update German translation

Veerasamy Sevagen (1):
      Display "No results" page for search

Yuri Chornoivan (2):
      Add Ukrainian translation
      Update Ukrainian translation

sevagen (4):
      ui: Add HeaderBarWidget
      nintendo-ds-layout-switcher: Implement HeaderBarWidget
      runner: Require extra widgets to implement HeaderBarWidget
      display-header-bar: Don't autohide when popovers are open


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]