[libxml++] Rename Element::add_content() to add_text_content?



I think we should rename these xmlpp::Element methods like so:
add_content() -> add_text_content() or maybe add_text().
get_child_content() -> get_child_text_content() or maybe get_child_text()
Set_child_content() -> set_child_text_content() or maybe set_child_text()
http://libxmlplusplus.sourceforge.net/reference/html/classxmlpp_1_1Element.h
tml
because that is what they do.

And that makes more sense now that we have added add_comment().

I have also thought about removing the add_ methods() becauase the set_()
methods do the same thing 90% of the time. The add_ methods are only useful
if you want to add more than one text or comment node. I suppose that's
slightly useful.

Thoughts?

Murray Cumming
www.murrayc.com
murrayc usa net




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]