[gtkmm] Dialog: get_vbox(): Return a Box instead of a VBox.



commit fa24dac983b002c9e2371c6cc82587d3bb282ed7
Author: Murray Cumming <murrayc murrayc com>
Date:   Wed Nov 10 11:32:09 2010 +0100

    Dialog: get_vbox(): Return a Box instead of a VBox.
    
    * gtk/src/dialog.hg: We need to rename this to get_content_area()
    anyway.
    We needed to change the return type, because the C function changed
    what it returned. I will fix its documentation.

 ChangeLog         |    9 +++++++++
 gtk/src/dialog.hg |    6 +++---
 2 files changed, 12 insertions(+), 3 deletions(-)
---
diff --git a/ChangeLog b/ChangeLog
index 93aa897..bfd7f55 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,12 @@
+2010-11-10  Murray Cumming  <murrayc murrayc com>
+
+	Dialog: get_vbox(): Return a Box instead of a VBox.
+
+	* gtk/src/dialog.hg: We need to rename this to get_content_area()
+	anyway.
+	We needed to change the return type, because the C function changed
+	what it returned. I will fix its documentation.
+
 2010-11-09  Armin Burgmeier  <armin arbur net>
 
 	* win32_installer/build-installer.sh: Make sure libintl-8.dll gets
diff --git a/gtk/src/dialog.hg b/gtk/src/dialog.hg
index 4647a86..8e8b14e 100644
--- a/gtk/src/dialog.hg
+++ b/gtk/src/dialog.hg
@@ -116,11 +116,11 @@ public:
 
   //TODO: Rename to get_content_area() when we do an ABI break.
   //We kept it as get_vbox() when reimplementing a MEMBER_GET with this new C function:
-  _WRAP_METHOD(VBox* get_vbox(), gtk_dialog_get_content_area)
-  _WRAP_METHOD(const VBox* get_vbox() const, gtk_dialog_get_content_area)
+  _WRAP_METHOD(Box* get_vbox(), gtk_dialog_get_content_area)
+  _WRAP_METHOD(const Box* get_vbox() const, gtk_dialog_get_content_area)
 
   _WRAP_SIGNAL(void response(int response_id), "response")
-  
+
   //_WRAP_PROPERTY("has-separator", bool) //deprecated.
 
   _IGNORE_SIGNAL("close")



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]