[grilo] Created tag grilo-0.1.7
- From: Juan A. Suarez Romero <jasuarez src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [grilo] Created tag grilo-0.1.7
- Date: Mon, 10 Jan 2011 13:43:55 +0000 (UTC)
The signed tag 'grilo-0.1.7' was created.
Tagger: Juan A. Suarez Romero <jasuarez igalia com>
Date: Mon Jan 10 10:35:56 2011 +0100
Grilo 0.1.7
Changes since the last tag 'grilo-0.1.6':
Chris Lord (1):
metadata-source: Don't try to free an uninitialised pointer
Damien Lespiau (7):
log: revamp the log system
log: rename the environment variable to GRL_DEBUG
log: rename grl_log_init() to grl_log_configure()
log: remove grl_log_init() calls from tools
build: fix parallel build of libs/net
wc-test: include unistd.h
tests: fix compilation warnings in metadata_source
Fabien Lebaillif - Delamare (1):
doc: fix typos
Guillaume Emont (2):
README: use --enable-uninstalled for grilo-plugins' autogen, not grilo's.
configure: remove unused --enable-uninstalled option
Iago Toral Quiroga (36):
Added --enable-uninstalled flag for autogen.sh in the "Examples" section.
core: unload plugins properly by calling g_module_close when appropriate.
core: when unloading a plugin, shutdown any sources it may have spawned.
test-ui: reloading functionality does not work as intended. This commit replaces plugin-reloading functionality by plugin-shutdown.
core: Do not free plugin descriptors in GrlMediaPlugin's finalize function, they are const members to be freed by the registry only when plugins are unloaded, they should not be freed when a source spawned by the plugin is unloaded.
test-ui: Reset combo boxes also when shutting down the plugins. test-ui: Make sure we only free each plugin once.
core: Free plugin data in the registry's plugin unload function.
doc: various documentation fixes.
core: Fix incorrect sorting of ranked plugins.
core: Fixed incorrect filtering of writable and supported keys. Bug was introduced in commit c592a85afc7c8538d91bb47b16a54c9dce8d5f46.
core: Fix compilation warning because of an unused label.
core: Add support for two new operations in GrlMediaSource - test_media_from_site - get_media_from_site
core: Implemented grl_multiple_get_media_from_site().
core: Do not use and idle destroy function for media_from_site, since
core: Add a list of metadata keys as input parameter for
core: Added flags input parameter to media_from_site() APIs.
core: renamed media_from_site API to media_from_uri.
core: Added GError parameter to grl_plugin_registry_register_source.
core: Added GRL_CORE_ERROR_UNREGISTER_SOURCE_FAILED
core: Added GError parameter to grl_plugin_registry_unregister_source
tests: Adapted to changes in grl_plugin_registry_unregister_source.
core: Added GRL_CORE_ERROR_LOAD_PLUGIN_FAILED
core: Added GError parameter to grl_plugin_registry_load
core: Added GError parameter to grl_plugin_registry_load_directory
core: Added GError parameter grl_plugin_registry_load_all
tests: Adapted to changes in grl_plugin_registry_load_all
grl-inspect: Adapted to changes in grl_plugin_registry_load_all.
test-ui: Adapted to changes in grl_plugin_registry_load_all
core: Added GRL_CORE_ERROR_UNLOAD_PLUGIN_FAILED
core: Added GError parameter to grl_plugin_registry_unload
test-ui: Adapted to changes in grl_plugin_registry_unload
core: Added GRL_CORE_ERROR_REGISTER_METADATA_KEY_FAILED
core: Added GError parameter to grl_plugin_registry_register_metadata_key
core: Added GRL_CORE_ERROR_CONFIG_FAILED
core: Added GError parameter to grl_plugin_registry_add_config
test-ui: Adapted to changes in grl_plugin_registry_add_config
Juan A. Suarez Romero (3):
build: fix grilo-net building
core: Add function to load plugin configuration from file
Bumped to version 0.1.7
Simon Pena (2):
python: add trivial error handling to grilo-test-ui
python: in test-ui, convert to strings when storing media info
Simón Pena (46):
core: Remove value destroy_func from the plugins' hash table
core: check for 'key-depends' implementation
annotations: Added missing colon
annotations: Replaced GObject.ParamSpec* with GObject.ParamSpec
annotations: Replaced Grl.Media* with Grl.Media
annotations: Replaced Grl.MediaSource* with Grl.MediaSource
annotations: Skipped non introspectable functions
core: Made GrlPluginInfo introspectable
annotations: Added missing transfer modes
annotations: Annotated grl-metadata-source
annotations: Annotated metadata_source cb GErrors as uints
annotations: Fixed 'get_info_keys' annotation
core: Replaced grl-media-plugin defines with functions
annotations: Annotated 'register_metadata_key'
annotations: Removed unnecessary annotations
annotations: Media in cb is transfer full
annotations: Fixed grl_data_get_keys transfer mode
doc: Updated examples to use new log system
core: Make get_sources return a GList
core: Make get_sources_by_operations return a GList
annotations: Fixed grl_init annotations
doc: Improve GrlMediaAudio documentation
doc: Improve GrlMediaImage documentation
doc: Improve GrlMedia documentation
doc: Add GrlLog documentation
doc: Fix GrlMediaVideo typo
doc: Skip GrlDataSync
doc: Added GrlError documentation
doc: Fix GrlUtil documentation
build: Define major, minor and micro version vars
build: Fixed gir build rules
vala: Improved metadata
core: Moved tests infrastructure to /tests
core: Updated infrastructure to support python tests
tests: Command line arguments can be passed to testrunner
tests: Tested the PluginRegistry class using GI
tests: Tested the PluginMedia class using GI
tests: Tested the MetadataSource class using GI
tests: Removed setUp/tearDown code in python tests
annotations: removed transfer mode for 'in' args
annotations: Fixed transfer modes in grl-metadata-source
core: reworked GrlMetadataSource's filter methods
tests: updated GrlMetadataSource filter tests
annotations: fixed GrlConfig annotations
python: added plugin configuration to grilo-test-ui
python: updated grilo-test-ui
VÃctor Manuel Jáquez Leal (42):
core: rename the GRL_ERROR quark to GRL_CORE_ERROR
log: handle numeric level assignations
bindings: add gmodule as link dependency
build: check hard pkg-config dependencies first
core: GrlMediaPlugin doesn't need finalize()
core: check for supported_keys implementation
core: a missing info doesn't deserve a warning
core: document the log level mapping
core: fix GrlLog gtkdoc documentation
build: detect new versions of vala
doc: add more documentation to grilo.c
doc: add more documentation to multiple search helpers
doc: trivial fixes
doc: new gtk-doc files
doc: change the main page layout
doc: enhance the documentation makefile
build: improve gir support in grilo-0.1.pc
build: improve path definition in grilo-uninstalled.pc.in
vala: check for libvala-0.12 instead of vala-0.12
vala: add MetadataSourceSetMetadataCb
vala: set domain name and fix instance positions
vala: fixed regression
wc: grilo net web client
wc: test app
build: libgrlnet
build: grilo-net pkg-config files
build: compile libs
grl-net: new header file
build: libgrlnet introspection
wc: gtkdoc documentation
doc: add the GrlNetWc definition
doc: fix the gtkdoc generation
vala: add grilo-net library bindings
tests: key filter gtests for GrlMetadataSource
core: fix when no slow/writable keys available
core: rename generic_filter() into filter_key_list()
vala: remove deprecated --metadata parameter in vapigen
Revert "doc: add the GrlNetWc definition"
Revert "doc: fix the gtkdoc generation"
doc: rename reference directory to grilo
doc: grilo-libs documentation
doc: update grilo core sections
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]