[clutter] Created tag 1.7.2
- From: Emmanuele Bassi <ebassi src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [clutter] Created tag 1.7.2
- Date: Mon, 13 Jun 2011 22:46:42 +0000 (UTC)
The signed tag '1.7.2' was created.
Tagger: Emmanuele Bassi <ebassi linux intel com>
Date: Mon Jun 13 23:30:08 2011 +0100
Clutter 1.7.2 (snapshot)
Changes since the last tag '1.6.6':
Adam Jackson (2):
test-cogl-blend-strings: Allow single-bit rendering error
test-cogl-sub-texture: Allow single-bit rendering error
Alejandro Piñeiro (5):
[cally] Fix a crash on some a11y examples if there isn't accessibility support
[cally] Removing default name and description
[cally] Added old cally Changelog (pre clutter-cally merge)
[cally] CallyRoot is the parent of any CallyStage object
[cally] Removed default actions on CallyActor
Alexandre Franke (1):
Fix typo
Andrej ŽnidarÅ¡iÄ? (2):
Updated Slovenian translation
Updated Slovenian translation
Chris Lord (1):
actor: Ensure the validity of the queue_redraw_entry pointer
Christian Kirbach (1):
[l10n] Updated German translation
Craig R. Hughes (1):
osx: Handle bare modifier keypresses
Dan Winship (1):
clutter-id-pool: fix warning on bad pick
Daniel Mustieles (17):
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Updated Spanish translation
Dioselin (1):
box: set default paint volume to allocation
Elliot Smith (5):
docs: Add effects chapter, with introduction and first recipe
docs: Add example of a border added through ClutterEffect
docs: Add example of setting background color with ClutterEffect
docs: Add recipe about implementing a ClutterEffect
docs: Remove checks for whether an effect is disabled
Emmanuele Bassi (118):
Post-release version bump to 1.6.7
docs: Remove last mention of SDL from the README
docs: Mention the cookbook in the README
text: Round up the size
Merge remote-tracking branch 'elliot/cookbook-effects-custom-deform'
build: Remove maintainer-clean rule
build: Remove MAINTAINERCLEANFILES from ChangeLog rules
Start 1.7 development cycle
event: Add setters for ClutterEvent members
build: Show CFLAGS in the configure summary
Move the keysym â?? Unicode table to .rodata
offscreen-effect: Add public accessor for target size
constraint: Queue a relayout on :enabled changes
effect: Queue a redraw on :enabled changes
x11: Use g_set_error_literal()
Clean up argument parsing GError handling
On error, return FALSE in the post_parse hook
glx: Use g_set_error_literal() where appropriate
event: Set the CrossingEvent device field
win32/event: Set the core pointer directly
event: Return the CrossingEvent.device field
box: Implement the correct paint volume
docs: Add an ClutterState definition section
settings: Clean up property installation code
settings: Add dnd-drag-threshold property
x11: Map Net/DndDragThreshold to ClutterSettings
drag-action: Allow using settings for the drag threshold
Add MarkDown version of the README
README.md: fix a dumb typo
AUTHORS: Note that the file is unmaintained
clutter.doap: Add my gnome userid
docs: Update RELEASING
Merge remote-tracking branch 'elliot/cookbook-effects-basic'
drag-action: Fix a compiler warning
doap: Fix the categories
build: Use AC_CANONICAL_HOST
build: Remove bash-isms
build: Fix previous commit
moduleset: Some modules have been moved to gnome.org
po: Track Clutter's POT file in Git
po: Update the PO files
texture: Add some safeguards for paint volumes of empty textures
paint-volume: Zero-sized actors don't have paint volume
align-constraint: Fix typo in the vertical align
build: Update the release rules
osx: Do not unrealize on hide
offscreen: Plug a leak in an error path
build: Fix typo in Makefile.am.release
doap: Update the project information
build: Look for sed
build: Generate the release announcement
build: Fix remote docs URI in the release-message
build: Cosmetic fixes for release targets
build: Fix typo in the docs URI variable name
glx: Remove unused variable
Point to GNOME for filing bugs
README.md: Fix all the links to Bugzilla
glx: Protect GLX SwapEvent symbols
Silence the compiler by removing unused variables
Silence another compiler warning
x11: Provide a StageWindow::unrealize implementation
glx: Chain up in ::unrealize()
Use the actor's debug name consistently
actor-meta: Add a get_debug_name() private method
actor: Use _clutter_actor_meta_get_debug_name()
animation: Use ::destroy with animate()
cogl/glx: Silence a compiler warning
evdev: Remove unused variable
cairo-texture: Make the pixel order macro public
stage: Use Cairo to dump the pick buffer
docs: Fix README.md to match README.in
build: Fix introspection rules
build: Specify the buildreq version for Cogl
build: Depend on cogl-pango-1.0
Deprecate actor id
Make the pick id pool per Stage
po: Remove a non existent file in POTFILES.in
text: Implement the ::has_overlaps virtual
text: Check the has_focus flag in selection_paint()
test-binding-pool: Remove usage of deprecated get_gid()
stage: Use the debug name for the pick buffer dump stem
shader-effect: Allow instantiating ShaderEffect
test-constrains: Use a ShaderEffect
Deprecate ClutterShader
actor: Avoid queueing redraws during destruction
stage: Bail out of do_update() when no impl is set
Eliminate G_CONST_RETURN
settings: Add the :long-press-duration
click-action: Add support for long press detection
test-bin-layout: Use the long-press signal on ClickAction
Fix deprecation guards for ClutterGLXTexturePixmap
event: Add clutter_event_set_source() declaration
docs: Fix up new symbols for the API reference
Move some old doc files under doc/
docs: Update the releasing checklist
clutter.modules: Update the moduleset
gesture-action: Clean up
swipe-action: Clean up
swipe-action: Remove the required devices call
gesture-action: Remove the multi-device entry points
docs: Add the new actions to the API reference
test-swipe-action: Clean up the test code
script: Allow connecting signal to ClutterState states
test-interactive: Add signal-based state transitions
script: Allow resolving signals states added from code
script: Rename "state" â?? "states"
script: Use a weak ref to remove the signal emission hook
Skip introspection for GValue â?? CoglFixed API
script: Allow warping to states
script: Plug a leak
docs: Update missing documentation
Merge branch 'swipe-action'
docs: Fix Clutter API reference
effect: Rename RunFlags to PaintFlags
release rules: Add note for snapshots
build: Fix up ChangeLog build generation
build: Put back ChangeLog.pre-git-import to unbreak distcheck
Release Clutter 1.7.2 (snapshot)
James Athey (3):
uniquely name and enable evdev ClutterInputDevice objects on creation
determine evdev device type using g_udev_device_has_property
GL_IMG_TEXTURE_NPOT extension enables TEXTURE_NPOT features on GLES
Jasper St. Pierre (4):
Remove private helper #define's
cogl-clip-state: Adapt to experimental cogl2 API.
tests: Add test for selected-text-color
clutter-text: Add a selected-text-color
Kjartan Maraas (2):
Add Norwegian bokmål translation.
Added Norwegian bokmål translation
Kristjan SCHMIDT (1):
Add Esperanto translation
Marek Ä?ernocký (5):
Czech translation
Updated Czech translation
Updated Czech translation
Updated Czech translation
Updated Czech translation
Mario Blättermann (1):
[l10n] Updated German translation
Matej UrbanÄ?iÄ? (6):
Added Slovenian translation
Updated Slovenian translation
Updated Slovenian translation
Updated Slovenian translation
Updated Slovenian translation
Updated Slovenian translation
Miguel Bouzada (1):
Updated Galician translations
Neil Roberts (53):
cogl-blit: Disable blending when using texture render
Add a conformance test for atlas migration
Add G_GNUC_WARN_UNUSED_RESULT to clutter_init and init_with_args
tests: Check return value of clutter_init_with_args instead of error
clutter-actor: Add an internal _clutter_actor_get_opacity_override
clutter-offscreen-effect: Preserve the old opacity override
clutter-offscreen-effect: Use 0,0 as the offset if no actor box
clutter-actor: Fix test for avoiding calculating the paint volume
cogl-shader-boilerplate: Specify default precision earlier
cogl-path: Optimise paths that are just a rectangle
cogl: Use GHookList instead of CoglCallbackList
mingw-fetch-dependencies.sh: Add a wrapper for pkg-config
clutter-offscreen-effect: Paint with 'nearest' texture filter mode
clutter-clone: Make clutter_clone_get_paint_volume static
cogl-pipeline: Be careful not to take ownership of root layer
cogl-pango-glyph-cache: Fix the flags passed to cogl_atlas_new
cogl-renderer: Move the XEvent filters to be generic for all renderers
cogl-context: Store winsys features in an array of unsigned ints
cogl-winsys: Move _cogl_winsys_has_feature to cogl-winsys.c
clutter-backend-glx: Protect against unrefing the Cogl context twice
cogl-winsys-glx: Fix the comparison in find_onscreen_for_xid
cogl-winsys-stub: Remove _cogl_winsys_has_feature
cogl-context: Initialize context->stub_winsys
cogl-pango: Use a separate glyph cache for mipmapped rendering
cogl-pango-display-list: Don't use VBOs if the texture can't handle it
cogl-atlas-texture: Split out new_from_bitmap to new_with_size
pango-glyph-cache: Try to put glyphs in the global atlas
cogl-atlas-texture: Add a callback for when any atlas reorganizes
cogl-pango-glyph-cache: Notify of reorg for global atlased glyphs
cogl-bitmap-private.h: Include cogl-bitmap.h
cogl-pango-render: Add the base texture to the display list
Revert "cogl-pango-display-list: Don't use VBOs if the texture can't handle it"
cogl-pango-glyph-cache: Don't put zero-sized glyphs in the cache
cogl-pango: Use a seperate cache of pipelines
cogl-pango: Don't set the special combine function for atlased textures
cogl_pipeline_equal: Handle COGL_WRAP_MODE_AUTOMATIC better
cogl-debug: Add an option to disable atlasing sharing
configure.ac: Remove the check for 'ffs'
win32: Use the Cogl WGL winsys
clutter-effect: Add a 'run' virtual
clutter-offscreen-effect: Don't redraw the actor if cached offscreen
clutter-effect: Add clutter_effect_queue_rerun
clutter-actor-meta: Add an internal 'priority' property
clutter-actor: Redraw or relayout when clearing effects or constraints
clutter-actor: Add an 'offscreen-redirect' property
Add a conformance test for the offscreen-redirect property
clutter-actor: Add a 'has_overlaps' virtual
clutter-actor: Store the queue_redraw_entry when queueing a redraw
Fix include location for cogl-pango.h
test-cogl-pixel-buffer: Use the new name for CoglPixelArray
test-cogl-depth-test: Update to new Cogl API
clutter-text: Don't move the cursor to the left when at pos 0
clutter-text: Use the ink rect in the paint volume
Peter Ward (1):
device: Prevent segfault
Philippe Normand (1):
clutter-text: new clutter_text_get_layout_offsets API
Piotr DrÄ?g (3):
Updated POTFILES.in and removed clutter-1.0.pot
Updated Polish translation
Imported translations from Transifex.net
Robert Bragg (69):
util: tune point_in_poly test for polys in screen coords
viewport: consistently use floats for viewports
stage: don't call glGetIntegerv in clutter_stage_read_pixels
matrix: adds 2d view transform conveniences
stage: simplify apply_transform
Optimize culling by doing culling in eye-coordinates
actor: Cache per-actor transforms
util: optimize _clutter_util_fully_transform_vertices
culling: check volume->is_empty before ->is_complete
debug: Add more CLIPPING debug notes
culling: Don't cull actors not being painted on the stage
win32: mkdir -p win32 needed for out of tree builds
win32: remove automatic build option from mingw script
win32: don't set CC,CPP,AR,NM,LD etc in mingw env.sh
win32: support building json-glib in mingw script
win32: Add blurb at end of mingw helper script
win32: Strip unneeded flags from env.sh
win32: remove deprecated -mno-cygwin options from env.sh
win32: remove env.sh generated by mingw-fetch-dependencies.sh
glx: throttle clipped redraws
pipeline: reclaim ownership if reverting to layer ancestor
paint-volume: Fix culling bug to handle partial culls
stage: Move _clutter_do_pick to clutter-stage.c
cogl: rename cogl-context.h cogl-context-private.h
cogl: Adds experimental cogl_context_new() API
cogl: consolidate _create_context_driver + _features_init
Remove unused _cogl_swap_buffers_notify
remove unused _cogl_features_init prototype
framebuffer: track context as CoglFramebuffer member
framebuffer: expose experimental cogl_get_draw_framebuffer
stage: adds internal_get_active_framebuffer API
actor: visualize culling with CLUTTER_PAINT=redraws
Add temporary cogl-clutter.h to aid splitting out Cogl
rename winsys files to be more consistent
Adds renderer,display,onscreen-template and swap-chain stubs
Moves all GLX code down from Clutter to Cogl
Adds the ability to build Cogl standalone
Adds a --with-system-cogl config option for Clutter
backend: remove untested fruity backend
Make cogl_framebuffer_get_width/height experimental public API
remove references to unused DRM_SURFACELESS EGL platform
Moves all EGL code down from Clutter to Cogl
texture-pixmap-x11: Move GLX code to cogl-winsys-glx.c
Add a vtable of indirection to the winsys code
winsys: Expose environment variable to choose winsys
Don't reference GL_STACK_OVERFLOW/UNDERFLOW for GLES
EGL: Updates GDL platform support
cogl/configure.ac: add options to control driver/egl platform
Adds Cogl Hello World and "X11 foreign" example applications
clutter/Makefile.am: mark clutter-cex100.h as BUILT_SOURCES
add missing Cogl bits to .gitignore
cogl/configure.ac: make COGL_HAS_xyz defines public
winsys-glx: map X window automatically if not foreign
cogl/configure.ac: Adds --enable-stub-winsys option
cogl-gl.c: remove really_enable_npot hack for OSX
cogl: remove OSX/WIN32 specific bits in favour of a stub winsys
cogl/Makefile.am: pass EXTRA_LDFLAGS for linking
cogl/configure.ac: fix pkg-config checks
cogl/configure.ac: check when building for win32
cogl/configure.ac: AC_SUBST an empty MAINTAINER_CFLAGS
cogl/pango/Makefile.am pass EXTRA_LDFLAGS for linking
Add missing _cogl_winsys_has_feature prototype
add missing name mangle for cogl_onscreen_set_swap_throttled
Adds cogl_onscreen_show/hide functions
Adds a way for Cogl to control event_mask of foreign wins
Removes Cogl from the repository
Remove last dependency on the GdkPixbuf API
culling: Use vertex_count not '4' to determine partial culls
build: include <cairo.h> not <cairo/cairo.h>
Samuel Degrande (1):
Removes the addition of the .exe extension to unit-test scripts, on win32.
Tomeu Vizoso (5):
clutter-offscreen-effect: use target size when setting up the viewport
Sync allocation in ClutterBoxLayout with the one in GtkBox
Add ClutterSwipeAction and ClutterGestureAction
Rename ClutterEffect::run to ClutterEffect::paint
Give a chance to effects for running when picking
nobled (2):
tests: abort if clutter_init fails
doc: fix clutter_init() usage in examples
�yvind Kolås (3):
stage: handle ACCEPT_FOCUS in set_/get_property
doap: fix a typo in a url
stage: ensure correct stage is current when picking
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]