[glib] Improve the wording of the message for G_UNAVAILABLE



commit 96c98ce62ebb88b296deab5391203a870dbfa068
Author: Matthias Clasen <mclasen redhat com>
Date:   Mon Feb 27 06:48:01 2012 -0500

    Improve the wording of the message for G_UNAVAILABLE
    
    The version number we have here is the one the function appeared
    in, not the max-allowed version. Therefore 'unavailable before
    VERSION' makes more sense than 'unavailable for VERSION'.

 glib/gmacros.h |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)
---
diff --git a/glib/gmacros.h b/glib/gmacros.h
index 0fbe71a..08f4035 100644
--- a/glib/gmacros.h
+++ b/glib/gmacros.h
@@ -317,9 +317,9 @@
 #endif
 
 #if    __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ >= 5)
-#define G_UNAVAILABLE(maj,min) __attribute__((deprecated("Not available for " #maj "." #min)))
+#define G_UNAVAILABLE(maj,min) __attribute__((deprecated("Not available before " #maj "." #min)))
 #elif defined(_MSC_FULL_VER) && (_MSC_FULL_VER > 140050320)
-#define G_UNAVAILABLE(maj,min) __declspec(deprecated("is not available for " #maj "." #min))
+#define G_UNAVAILABLE(maj,min) __declspec(deprecated("is not available before " #maj "." #min))
 #else
 #define G_UNAVAILABLE(maj,min)
 #endif



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]