[librsvg] Created tag 2.41.2



The signed tag '2.41.2' was created.

Tagger: Federico Mena Quintero <federico gnome org>
Date: Fri Dec 8 16:28:45 2017 -0600

    Librsvg 2.41.2

Changes since the last tag '2.41.1':

Chun-wei Fan (1):
      Visual Studio builds: Enhance security of x64 binaries

David Michael (1):
      Support cross-compiling with Rust

Federico Mena Quintero (177):
      Have "make V=1" pass --verbose to "cargo build"
      Post-release version bump to 2.41.2.
      Remove unused imports
      parse_transform.lalrpop: Only make parse_Num and parse_TransformList public
      lib.rs: sort the list of modules
      RsvgLength::check_nonnegative(): New method
      structure.rs: Use RsvgLength::check_nonnegative() instead of doing it by hand
      marker.rs: Use the correct horizontal/vertical default size
      shapes.rs: Use RsvgLength::check_nonnegative()
      structure.rs: Use RsvgLength::check_nonnegative()
      marker.rs: Per the spec, check that markerWidth/markerHeight are nonnegative
      shapes.rs: Use property_bag::length_or_none() in a spot that was missing
      property_bag.rs: Implement parse_or_default() in terms of parse_or_value()
      Oops, unref nodes after boxing them and using them.
      test-utils.c: Fix a leak
      parsers::Parse - new trait; we'll use this instead of std::FromStr
      impl Parse for cairo::Matrix; remove property_bag::transform_or_none()
      impl Parse for RsvgLength
      Remove property_bag::length_or_*(); use parse_or_() instead
      impl Parse for Color
      Remove unused imports
      parse_or_*() - Take an extra argument, a validation function
      RsvgLength::check_nonnegative(): Take ownership of self
      Move all the RsvgLength::check_nonnegative() calls to the validation function
      RsvgLength::new() - new method.
      NodeStop: validate "offset" using a validation function
      parse_or_value(): implement in terms of Option::unwrap_or()
      Makefile.am: Oops, list README.md in dist_doc_DATA
      drawing_ctx.rs: Bind rsvg_render_surface()
      Remove unused imports
      image.rs: Move NodeImage over to Rust.  Yay!
      Move utility function in rsvg-image.[ch] to rsvg-base.c.
      viewport.rs: new draw_in_viewport() function
      structure.rs: Factor out some duplicated code
      Set the current state's affine in the generic function
      draw_in_viewport(): Take in a clip_before_layer_push argument
      NodeUse::draw(): use draw_in_viewport()
      draw_in_viewport(): Don't pass an affine to the callback; it's implicit now
      Implement draw_in_viewport() indirectly so we can have some tests
      viewport.rs: Start adding tests
      marker.rs: Compute the rotation with less code
      marker.rs: Start directly with the state's current transformation, not an identity
      draw_in_viewport(): Take in a ClipMode enum instead of an obscure boolean
      viewport.rs: Disable rendering if the viewBox size is 0, per the spec
      viewport.rs: Make the order of operations consistent
      viewport.rs: Give better names to the test functions
      wip: marker.rs: make order consistent with viewport
      Remove test for 760180.svg - it is the same SVG as painting-marker-06-f.svg
      ViewBox::new() - new constructor
      Update an out-of-date Sodipodi (!) file to plain SVG to use for testing
      Add compressed version of the last test file
      Add new test files to tests/Makefile.am
      tests/loading.c: New tests for the loading machinery
      rsvg-base.c: Use constants for the gzip header magic
      Allow loading one byte at a time with rsvg_handle_write()
      Run the loading tests first... they are kind of the basic smokee tests
      Test reading compressed SVGs one and two bytes at a time
      Rename the loading tests to have a "/loading/" prefix
      Rename data_input_stream to compressed_input_stream for clarity
      Create the compressed_input_stream in a separate function
      Use a different reading state when reading compressed data
      Comment about having to slurp the whole compressed file if using write()/close()
      Use xmlCtxtUseOptions() instead of setting ctxt->options directly (!)
      Set replaceEntities where we set the rest of the XML parser's options
      Remove unnecessary argument
      Centralize a function to create an libxml2 parser
      Un-inline a function (we'll change the callers), and tighten assertions
      bgo#787895 - Use xmlCreateIOParserCtxt() for I/O callbacks instead of a push parser
      Rename create_xml_push_parser()
      Factor out create_xml_stream_parser()
      Delete TODO; it's obsolete
      Convert the toplevel rsvg-docs.xml to DocBook 5.1
      Update the toplevel docs with a better description of what librsvg is
      Add an overview to the docs
      Mention the ability to render a subset of the SVG
      RsvgHandle: Add useful toplevel docs
      Fix "/*" inside comments
      Test the toplevel parse_transform(), not the lalrpop-generated implementation
      Fix some compiler warnings
      No need to test parse_Num() from lalrpop
      Make the toplevel README.md more hospitable
      Cross-link between README.md and CONTRIBUTING.md
      README.md: light editing
      Make CONTRIBUTING.md friendlier to non-git.gnome.org users
      tests/README.md: Update for the new test types
      Markup fixes
      configure.ac: Put the cross-compiling machinery all together
      Makefile.am: Indent the cargo build command more nicely
      Makefile.am: Refactor some variable substitutions
      COMPILING.md: New file with details on compilation options
      Try to fix internal links in COMPILING.md
      Again...
      COMPILING.md: Mention Cargo's shenanigans of downloading sources
      Merge branch 'hospitality'
      Merge remote-tracking branch 'origin/master'
      Makefile.am: Oops, I deleted a "cargo" command
      Make RsvgClipPath private; provide an accessor for its only field
      clip_path.rs: Move the clipPath implementation to Rust.  Yay!
      Update Cargo.lock
      CONTRIBUTING.md: markup fixes
      Fix links to code_of_conduct.md
      Fix links to code_of_conduct.md
      Rename PaintServerUnits to CoordUnits
      New macro coord_units! to create newtypes over CoordUnits with a default value
      coord_units.rs: Test the default value and converter
      Remove the C binding to AspectRatio; it's no longer used
      Make _rsvg_handle_allow_load() take a GFile for the base uri, not a handle
      rsvg_allow_load(): Rename from _rsvg_handle_allow_load(); make it public
      rsvg_acquire_data_data(): Remove unused argument
      Add emacs indentation magic
      rsvg_decode_data_uri(): Renamed from rsvg_acquire_data_data()
      rsvg_handle_resolve_uri(): Make public
      rsvg_handle_new_from_file(): Use the GFile machinery to convert a filename to a URI
      rsvg_get_base_uri_from_filename(): Make private
      rsvg-io - Don't resolve relative filenames here; do it in the caller
      Clean up rsvg-defs a bit
      Merge branch 'no-xrefs-in-paint-servers'
      rsvg_cairo_generate_mask(): Rename variable
      RsvgMask: make private; provide accessor functions
      mask.rs: Port NodeMask completely to Rust.  Yay!
      Some test files were not in git!?
      Add reftests/bugs/761175-recursive-masks.svg for the previous commit
      bgo#761175 - Allow masks to (re)use a node being referenced
      rsvg_text_render_text(): Make static
      rsvg_make_valid_utf8(): Take a "gssize len", like glib functions do
      rsvg_node_chars_append(): Factor out a way to append characters to a chars node
      rsvg_node_chars_new(): Make the caller use rsvg_node_chars_append() for the initial contents
      Simplify the code flow in rsvg_characters_impl()
      RsvgNodeChars: Make private; provide an accessor rsvg_node_chars_get_string()
      Provide and bind rsvg_state_set_cond_true() to Rust
      Port NodeChars to Rust.  Yay!
      Makefile.am: sort the lists of source files
      Rename rsvg-gobject.c to rsvg-handle.c
      rsvg-handle.c: Move the constructors here from rsvg-base.c
      rsvg-handle.c: Move more RsvgHandle methods here
      write_impl(): Internal function renamed from rsvg_handle_write_impl()
      close_impl(): Internal function renamed from rsvg_handle_close_impl()
      Limit the "const xmlChar *ch, int len" madness to libxml callbacks
      find_last_chars_child_in_text_or_tspan(): Extract this from rsvg_characters_impl()
      rsvg-base.c: Factor out node_is_text_or_tspan()
      rsvg_characters_impl(): Remove redundant check
      rsvg_characters_impl(): Extract function to create a new chars child node
      Use g_utf8_make_valid() instead of our own; require glib 2.52.0
      _rsvg_node_text_type_tspan(): Push/pop the current state here, not in the caller
      _rsvg_node_text_length_children -> compute_length_from_children
      _rsvg_node_text_length_tref -> length_from_tref
      _rsvg_node_text_length_tspan -> length_from_tspan
      Align argument lists to make it easier to see differences
      _rsvg_node_text_type_children -> draw_from_children
      _rsvg_node_text_type_tspan -> draw_tspan
      _rsvg_node_text_type_tref -> draw_tref
      Align argument lists to make it easier to see differences
      Remove RsvgTextLayout; make rsvg_text_length_text_as_string() standalone
      rsvg_text_length_text_as_string -> measure_text
      s/create_pango_context/get_pango_context throughout
      measure_text(): Don't frob the ctx->render->pango_context here
      Add text-align-01-b and text-align-03-b from the SVG 1.1 test suite
      Allow having more than one font for the testing machinery
      Add Roboto fonts, remove LiberationSans, and normalize reference tests
      Add text-text-03-b.svg from the SVG 1.1 test suite
      Add text-text-08-b.svg from the SVG 1.1 test suite
      Add text-text-10-t.svg from the SVG 1.1 test suite
      space.rs: New file to deal with xml:space normalization
      space::normalize_preserve() - Use iterator functions instead of making fire by rubbing sticks
      space.rs: Include the relevant portions of the spec
      Export rsvg_xml_space_normalize() from Rust to C
      Use rsvg_xml_space_normalize() instead of _rsvg_text_chomp()
      Regenerate two test reference files after whitespace changes
      Remove the "lastwasspace" tracking from rsvg-text.c
      Reimplement normalize_default() with the magic of iterators
      COMPILING.md - fix the example of how cross-compilation variables get passed
      Update NEWS
      Remove TODO from the Makefile.am; it no longer exists
      Add missing files to the distribution
      Fix the documentation infrastructure a bit
      Fix the source path in doc/Makefile.am
      doc/Makefile.am: Generate in xml mode

Philip Withnall (3):
      rsvg-filter: Use fabs() instead of abs() for floats
      rsvg-styles: Fix badly structured comparisons
      rsvg-styles: Fix indentation


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]