[librsvg] Created tag 2.45.0
- From: Federico Mena Quintero <federico src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [librsvg] Created tag 2.45.0
- Date: Sat, 17 Nov 2018 10:57:38 +0000 (UTC)
The signed tag '2.45.0' was created.
Tagger: Federico Mena Quintero <federico gnome org>
Date: 1542452227 -0600
Tag for version 2.45.0
Changes since the last tag '2.44.0':
Antonio Ospite (1):
(#365): rsvg-convert: Specify pixel dimensiosn for SVG output
Benedikt Heine (2):
Fix memory leak
Fix memory leak in handle
Federico Mena Quintero (206):
rustfmt
Merge branch 'issue324' into 'master'
Add xml processing instruction
Bump version to 2.45.0
Do the full CI on the librsvg-2.44 branch
Tree leak
Merge branch 'tree-leak' into 'master'
Merge branch 'link-order' into 'master'
gitlab#325 - rsvg_tree_free(): Cast the tree to our real Tree so it will get dropped
compute_luminance_to_alpha(): Take ownership of the surface; return it again
compute_luminance_to_alpha(): Return a Result
gitlab#328 - Make masking work on big-endian
Merge branch 'masking-endianness' into 'master'
distcheck-hook: remind myself to use DESTDIR, or distcheck won't work
Merge branch 'bz689832' into 'master'
Merge branch 'state' into 'master'
Merge remote-tracking branch 'origin/master'
ViewParams: new struct to hold values required for Length normalization
Length.normalize(): Take a ViewParams, not a whole DrawingCtx
Length: basic tests for normalization
Length: Basic tests for FontEm / FontEx normalization
font_props: Take a ViewParams for our normalization functions, too
Remove unused functions
DrawingCtx::push_view_box(): Return a ViewParams object
ViewParams: Use accessor functions; make fields private
DrawingCtx: rename vb_stack field to view_box_stack
DrawingCtx: Keep the whole stack of viewboxes in the view_box_stack
DrawingCtx: store the view_box_stack in a RefCell
Remove DrawingCtx::pop_view_box() in favor of an impl Drop for it
Remove unused variable
Docs for push_view_box()
ViewParams: keep a Weak reference to the view box stack, not a strong one
Merge branch 'pborelli/librsvg-cleanup'
Merge branch 'bochecha/srcdir-builddir'
(#335): Don't panic if the toplevel node is not <svg>
tests/errors: Test that a non-svg toplevel element gives us a parsing error
Don't chain calls to finish_load() and the function whose result it depends on
(#335): Return an error when the toplevel element is not <svg>
Merge branch 'non-svg-toplevel' into 'master'
Merge branch 'YaLTeR/librsvg-fix-crashes'
Update NEWS
Remove unused macro_use
(#337) - Don't panic with "ex" or "em" units in the font-size property
(#338): Don't panic when an image element doesn't have width/height attributes
(#340): Don't panic when a marker has a zero-sized viewBox attribute
AcquiredNodes: Use a Rc<...> instead of a raw pointer into the Vec of acquired nodes
AcquiredNode.get(): Return a reference, not a cloned Rc<>
NodeUse: release the acquired child as soon as possible
(#342): Don't crash if a <use> node references one of its ancestors
Remove unused function
filters::render() - Take the computed values of the node being filtered, not the whole node
Fix error message
Minimal docs for AttributeError and NodeError
Rename AttributeError to ValueErrorKind
Rename methods to set styles from a pbag
Tighten an unsafe block
Split the scary Node.set_style() into three smaller functions
Node: add an element_name field
Now that nodes know their element name, don't pass it down the rsvg_load_set_node_atts() chain
AspectRatio: don't use a helper function to parse
Align::parse_xy() - Take the full ident, not the &str version
parse_align_xy(): This should be a standalone function, not a non-method
parse_fit_mode(): This should be a standalone function, not a non-method
Makefile.am: Fix the location of the enum timestamp files
(#341): Don't infinite-loop with cyclic pattern references
Makefile.am: Don't generate a ChangeLog for distribution anymore
Update NEWS
Delete old samples and bugs directories
path_parser.rs: format the tests nicely and ask rustfmt to skip them
(#345): path_parser.rs: Numbers must have digits; they can't consist of a single dot
with_discrete_layer(): Propagate errors from cairo::ImageSurface::create()
Remove stray printlns
FilterContext::into_output(): propagate errors more simply
with_discrete_layer(): Separate out the filter rendering and propagate errors from it
Update NEWS
rustfmt
(#344): Don't let a viewBox with overflowing numbers pass through
Update NEWS
Remove unused function
css.rs: New file; start porting the CSS processing code to Rust
rsvg_handle_get_dimensions_sub() - Don't panic if we get passed a nonexistent fragment identifier
rsvg-dimensions.c: Fix the GOptionEntry for G_OPTION_REMAINING
rsvg-dimensions.c: Be clear on whether a fragment is not found, or whether its position/dimensions
could not be computed
compute_text_bbox(): Don't mutate the bbox directly; use its methods
BoundingBox::with_ink_rect() - new method, analogous to with_ink_extents()
tests/dimensions.c: Add infrastructure to test for object positions
(#347): Set the ink_rect of Pango layouts, not just their objectBoundingBox rect
Merge branch 'sub-positions' into 'master'
Merge branch 'YaLTeR/librsvg-fix-filters'
Oops, add css.rs to Makefile.am
tests/Makefile.am: List the dimensions and styles fixtures with wildcards
croco.rs: Minimal hand-written binding to the part of libcroco that we need
css.rs: Basic skeleton for the CRDocHandler vtable
css.rs: Move most of the libcroco callbacks to Rust
Move CSS importing to Rust
Move rsvg_css_parse_color_() to rsvg-base.c
Remove rsvg-styles.c - yay!
Add test for CSS imports.
Merge branch 'css-processing' into 'master'
DrawingCtx.get_pango_context() - Use dpi_y for the Pango context's resolution
Round when converting userspace units to Pango units, which are ints
(#348): Fix incorrect font sizing
Merge branch 'font-size-scaling' into 'master'
(#349): Don't panic when loading an external image that is bigger than Cairo's limits
Merge branch 'too-large-image-data' into 'master'
RsvgSaxHandlerStyle - don't use an RsvgSaxHandlerDefs struct to store the parent handler
rsvg-load: Remove superfluous checks for the vtable functions
rsvg-load: Fix use-after-free in style_handler_end()
rsvg-load: Fix use-after-free in xinclude_handler_end() if it were called
Don't use a global variable for the xmlSAXHandler
RsvgLoad: move all the XML state to a separate structure
xml.rs: New file; start moving the XML parsing state to Rust
Move the "currentnode" to XmlState in Rust
Port the element_name_stack to Rust
Port standard_element_start() to Rust
Inline rsvg_load_set_node_atts() in its only caller
standard_element_end(): Extract this function from sax_end_element_cb()
Port standard_element_end() to Rust
Minimal docs for XmlState
Port characters_impl() to Rust; it's now add_characters()
Remove a bunch of unused functions
XmlContext: new trait for XML parsing contexts
Rewrite the machinery for nested XML handlers in Rust
Some documentation for XmlState
NodeCreationContext: move the actual node creation to its own function
NodeCreationContext: add a case for the <style> element
NodeCreationContext: provide a little constructor for the initial case
Return Option from end_element() and get_node() in XmlHandler
Port <style> element handling to Rust
rsvg-load.c: Remove leftover handling of the <style> element
defs::Reference - encapsulate the micro-parser for uri#fragment_id
Defs::lookup() - Use Reference::parse() instead of doing the parsing here
feImage: Use Reference::parse to see if we are dealing with a node or a whole image
node.rs: Remove unused import
end_element: rename svg.set_delayed_style()
characters(): pass element name to node_new()
create_node() - don't pass element name to new_node.set_style()
node.rs: remove unused import
tests/dimensions.c: Make assertions in the main test function more useful
Merge branch 'alatiera/ulong' into 'master'
(#349): Don't panic if we get a "data:" URI with empty data.
SharedImageSurface::from_pixbuf() - Implement this in Rust
error::LoadingError: new error enum for the loading stage
handle::image_surface_new_from_href() - Port to Rust
rsvg_cairo_surface_from_pixbuf(): Removed
rustfmt
Merge branch 'surface-from-href' into 'master'
Merge branch 'fix-convolve-matrix-allocation' into 'master'
cargo update
Remove unused function
Use the locale_config crate
Use the language_tags crate
(#256): Fix matching of the systemLanguage attribute with the user's locale
rustfmt
rsvg-test.c: Add plain "en" to the locale so the systemLanguage tests pick it up
rsvg-test.c: Override the environment's locale with LC_ALL
Merge branch 'system-language' into 'master'
Pass the previous_handler down to the start_element implementations
(#320) - Parse XmlLang as an identifier, not a CSS string
Merge branch 'xml-lang' into 'master'
(#334): Preserve the cairo_t's transformation matrix during rendering
Merge branch 'preserve-matrix-during-rendering' into 'master'
(#358) - Use assert_approx_eq_cairo in tests
Remove unused #[repr(C)]
Update minimum cairo version in COMPILING.md
(#359): Require rust 1.27
rustfmt
Merge branch 'smcv/librsvg-non-x86-tolerance'
NodeChars: Do xml:space normalization only once
Factor out some duplicated code
XmlSpaceNormalize: new enum to specify how to trim spaces in xml_space_normalize()
(#363): Fix whitespace removal around <tspan> elements
Merge branch 'space-in-text-element' into 'master'
Merge branch 'smcv/librsvg-save-all-diffs'
Merge branch 'smcv/librsvg-more-i386-tolerance'
(#368): Log when an element is not rendered due to a nonexistent filter
NodeTRef: log if the referenced element is nonexistent
marker.rs: Log when a referenced marker is not found
DrawingCtx: log when an element references a nonexistent mask
gradient.rs: Log when referencing a nonexistent gradient
paint_server.rs: Log when there is a nonexistent pattern with no alternate
NodeUse: Log when referencing a nonexistent element
pattern.rs: Log when we find a circular reference
Merge branch 'log-nonexistent-references' into 'master'
(#371): rsvg-convert - Fix positioning of extracted elements when they are scaled
NodePath: Log when path commands cannot be parsed
(#372): Fix mis-rendering in small arc segments
Merge branch 'small-arc-segments' into 'master'
(#373): Render gradients with userSpaceOnUse even for an empty bounding box
Merge branch 'gradient-userspaceonuse' into 'master'
Remove unused prototypes
wip: xinclude, in acquire_text()
Don't use dynamic dispatch for the XML handlers; we only have three cases anyway
XmlState: split style_start_element() into valid and invalid cases
Merge branch 'memleak' into 'master'
wip: xinclude fallback
wip: xinclude for text
cargo fmt
Use a real NodeStyle for the <style> element instead of special loading logic
Support <xi:include parse="text"> inclusions
Make xi:fallback work for the <xi:include parse="text"> case
Add tests for xi:include in text mode
Hook up the C code to handle XML xi:include into the Rust code
Remove unused C code for XML loading
Merge branch 'xml-processing'
Update NEWS
Ivan Molodetskikh (10):
Fix a feConvolveMatrix crash when kernel isn't set
Fix filters crashing on non-invertible paffine
Fix upper bound in PixelRectangle get_pixel clamp
Add a sanity check to PixelRectangle
Add FilterError::ChildNodeInError
(#343): Handle child being in error in feComponentTransfer
Handle child being in error in feMerge
Handle child being in error in feLighting
(#346): Return Cairo errors from filters
(#352): Parse kernelMatrix as an unbounded list
Jordan Petridis (9):
CI: disable tests based on debian tests
CI: run make && make check
CI: Do not fail if _build exists
CONTRIBUTING.md: Update rustfmt documentation
Merge branch 'alatiera/rustfmt-docs' into 'master'
css.rs: Fix usize cast
CI: Move cache setup inside the script
CI: Enable debian tests again
CI: Minor yaml formatting change
Linus Unnebäck (2):
Explicitly add hidden lifetime parameters
Fix formatting errors
Mathieu Bridon (2):
build: Fix building with srcdir != builddir
ci: Build with srcdir != builddir
Paolo Borelli (12):
Do not assert if we ask dimensions of a file with no ink box
tests: add a reftest for BZ#689832
state: cleanup unused exports and declarations
node: Use a RefCell for the State
gradient: shorten code
gradient: shorten code
gradient: add a test for fix_focus_point
state: do not manually implement Default for ComputedValues
state: split out parse_attribute_pair
Make rsvg_state_parse_style_pair take attr as a string
attribute: implement fmt::Display
gradient: do not mutate input focus point coordinates
Simon McVittie (4):
Use LIBRSVG_LIBS, LIBM to satisfy dependencies of RUST_LIB
tests: Tolerate greater rendering differences on all non-x86_64
tests: Log and save a diff if max_diff exceeds x86_64 tolerance
(#366): tests: Increase reftest tolerance on non-x86_64 even more
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]