[librsvg] Created tag 2.45.5
- From: Federico Mena Quintero <federico src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [librsvg] Created tag 2.45.5
- Date: Sat, 16 Feb 2019 00:19:12 +0000 (UTC)
The signed tag '2.45.5' was created.
Tagger: Federico Mena Quintero <federico gnome org>
Date: 1550276319 -0600
Tag for version 2.45.5
Changes since the last tag '2.45.4':
Federico Mena Quintero (114):
Post release version bump
rsvg_handle_new_from_gfile_sync(): Port the implementation to Rust
Fix a little bunch of leaks in the test suite
Handle::get_dimensions() - Don't call out to the C code
Fix more leaks in the test suite
Defs: free the extern RsvgHandles on Drop
rsvg_handle_new_from_data(): Port the implementation to Rust
Handle::get_dimensions_sub(): Move implementation from rsvg_handle_rust_get_dimensions_sub()
Handle::get_dimensions(): Move implementation from rsvg_handle_rust_get_dimensions()
Handle::get_position_sub(): Move the implementation from rsvg_handle_rust_get_position_sub()
handle.rs: Remove the raw handle pointer argument from a bunch of functions
load_css(): Move to css.rs
CssStyles: Move two functions into methods here
Move the surface-to-pixbuf code to a separate file
Turn Handle::get_pixbuf_sub() from a method to a standalone function
impl Error for RenderingError
rsvg-pixbuf.c: Port all the functions here to Rust
Makefile.am: rsvg-view doesn't require rsvg-size-callback.h
Move rsvg-size-callback into rsvg-convert.c
Merge branch 'pborelli/librsvg-defs'
text.rs: Prefix unused struct fields with _
DrawingCtx::with_discrete_layer(): Simplify the clip path code a bit
(#268) - Remove the comp-op property; it's not in SVG 1.1 not SVG 2
Resources: Don't store raw RsvgHandles, store just Svg
Merge branch 'pborelli/librsvg-aurl'
Svg::lookup_image(): Return a SharedImageSurface
Merge branch 'pborelli/librsvg-load'
rsvg_handle_new_from_file(): Port the implementation to Rust
rsvg_handle_new_from_flags(): Port the implementation to Rust
RsvgHandle: Don't store a priv field
handle.rs: Take an RsvgHandle, not a Handle, into the functions exported to C
Merge branch 'pborelli/librsvg-cleanup'
Merge branch 't6/librsvg-patch-use-configured-rust-toolchain'
COMPILING.md - describe the RUSTC and CARGO environment variables
Merge branch 'pborelli/librsvg-vbox'
(#405): Oops, free an error properly.
Update NEWS
NodeMask: separate the functions to get the default x/y/width/height
NodeMarker: Separate the function to get the default size
Replace FilterContext::with_primitive_units() by a get_view_params()
Split Length into LengthHorizontal/LengthVertical/LengthBoth
font_size_from_inch(): Renamed to inches_to_pixels()
inches_to_pixels(): Inline in one of its callers
LengthDir::scaling_factor(): Extract the direction-specific scaling computation to here
inches_to_pixels(): inline into the only caller
ViewParams: Make the numeric fields public to avoid accessors
LengthDir::scaling_factor(): Take plain values, not functions
length.rs: Don't use Length in the tests; use LengthHorizontal, etc.
Length::normalize(): Inline into its only caller (the macro to create Length* types)
font_size_from_values(): No need to look at the direction; it's always Both
Length: remove the 'dir' field
NumberList: Don't use the Parse trait; implement similar methods directly
Remove Parse's Data associated type. Yay!
Use the master branch of the gtk-rs crates, for glib's subclassing feature
gio::content_type_get_mime_type() changed return type
Adjust for changes in cairo::Status vs. cairo_sys::cairo_status_t
Start porting the GObject boilerplate to use glib::subclass
Use expect() instead of unreachable() for the property value checks
Use unreachable!() for invalid property IDs
check_is_loaded() - Renamed; return a Result instead of a bool
check_is_loaded(): turn into a method of Handle
Do the check_is_loaded() checks in the Handle methods, not in the public API implementations
Handle::has_sub() - Move the implementation to this method
rsvg_handle_rust_get_pixbuf_sub(): Move the loaded check to the helper function
Handle::get_pixbuf_sub() - Turn into a method
Handle::get_dimensions_no_error(): Implement the error-less version here
handle.rs: Make some fields/methods public so c_api.rs can use them
Handle::read_stream_sync(): Take a &self, not &mut self
Make Handle.buffer a RefCell so all fields have interior mutability
Handle::create_drawing_ctx_for_node(): Take a &self, not &mut self
Handle: make all methods take &self, not &mut self
Handle::get_property() - Implement
Handle::constructed() - Removed; we can use the default implementation
tests/api.c: Add tests for all the GObject properties in RsvgHandle
handle.rs: Make all functions take a *const RsvgHandle
get_rust_handle() can now return a &Handle, not a &mut Handle
Bind RsvgHandleFlags with bitflags, to Rust
Finish porting the GObject boilerplate to Rust. Yay!!!!!!!
Fix typo
Remove a few unused prototypes
tests/README.md - Update for all the new test programs
Update deprecation documentation for the size_callback
Add deprecation guards to RsvgDimensionData / RsvgPositionData
RsvgDimensionData/RsvgPositionData - Add descriptions
Docs: mention gradual inclusion of SVG2 features
Docs: specify the full set of rules for resolving relative URLs
Docs: Expand the RsvgHandle description with details on preferred loading methods
Merge branch 'subclass'
Include documentation for RsvgHandle properties
Try to make Docbook 5 really work...
Remove deprecation markers on the types, or gtk-doc won't include them
Don't try to document RsvgHandlePrivate; it doesn't exist anymore
Add docs for librsvg_version and associated variables
Include RsvgRectangle in the docs
doc/Makefile.am: only scan the sources under librsvg/, not the tests as well
rsvg.symbols: add rsvg_handle_get_geometry_sub
Use __GTK_DOC_IGNORE__ to ignore internal macros/functions
Align the function arguments in the public headers
Revert the subclass branch temporarily
Merge branch 'revert-subclass-temporarily'
(#409) - Fix introspection annotations for rsvg_handle_get_geometry_sub()
DrawingCtx: remove the surfaces_stack
compute_effects_region(): Make into a method of NodeFilter
feImage: Pass the bounding boxes to render_external_image()
Update Cargo.lock; this just adds an auto-generated comment
Update COMPILING.md
Merge branch 'alatiera/pixbuf-utils-comp' into 'master'
build.rs: Move the call to generate_srgb_tables() to the correct place
README.md: Link to the other GUADEC presentation on librsvg
Register enums and flags against GType in Rust
tests/api.c: Test all the RsvgHandleFlags values
(#415): Test the all the values in the RsvgError enum
doc/Makefile.am: there are no generated C sources in builddir anymore
Update NEWS
Jordan Petridis (1):
Update compiling docs for debian
Kornel LesiĆski (1):
Don't use private enums submodule
Paolo Borelli (28):
svg: create Defs internally to Svg
Remove defs.rs and move to the relevant files
dpi: remove interior mutability
svg: remove css_styles, it is unused
svg: fix order of params in ::new()
svg: store LoadOptions, not the raw handle
handle: pass around LoadOptions instead of the raw handle
xml: make steal_result return a Result
svg: make the tree member private
svg: cascade the tree when the Svg is loaded
tree: remove module
handle: cleanup close
drawing_ctx: make code easier to follow
allowed_url: rename PlainUri to PlainUrl for consistency
allowed_url: implement deref
svg: store image resources in the svg struct
svg: improve lookup error handling
image: move lookup to an inner scope
image filter: use approx_eq_cairo to check w and h
load: remove legacy load context
handle: remove has_sub
image: use the same code to parse href in image and filters/image
allowed_url: do not use Href::with_fragment
state: pull important_styles set out of State
state: remove the State struct
Rename state.rs to properties.rs
vbox: do not wrap a cairo rectangle
number_list: refactor a NumberList type
Tobias Kortkamp (1):
Support selecting a different Rust toolchain
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]