[gnome-shell] workspace: Rename show-close-button signal to chrome-visible
- From: Florian Müllner <fmuellner src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gnome-shell] workspace: Rename show-close-button signal to chrome-visible
- Date: Thu, 31 Jan 2019 17:47:29 +0000 (UTC)
commit 6b0c8c9fe02f7dcb114d0c700c724de5f13a136e
Author: verdre <verdre v0yd nl>
Date: Mon Nov 19 12:28:28 2018 +0100
workspace: Rename show-close-button signal to chrome-visible
Since we no longer only show the close button but the whole window
chrome on hover, change the name of the signal.
https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/346
js/ui/workspace.js | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
---
diff --git a/js/ui/workspace.js b/js/ui/workspace.js
index a60b6a209..31892e56a 100644
--- a/js/ui/workspace.js
+++ b/js/ui/workspace.js
@@ -670,7 +670,7 @@ var WindowOverlay = class {
return;
this._animateVisible();
- this.emit('show-close-button');
+ this.emit('chrome-visible');
}
_onHideChrome() {
@@ -1855,7 +1855,7 @@ var Workspace = class {
this.actor.add_actor(clone.actor);
- overlay.connect('show-close-button', () => {
+ overlay.connect('chrome-visible', () => {
let focus = global.stage.key_focus;
if (focus == null || this.actor.contains(focus))
clone.actor.grab_key_focus();
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]