[vala] Created tag 0.47.1
- From: Rico Tzschichholz <ricotz src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [vala] Created tag 0.47.1
- Date: Mon, 11 Nov 2019 12:07:56 +0000 (UTC)
The signed tag '0.47.1' was created.
Tagger: Rico Tzschichholz <ricotz ubuntu com>
Date: 1573472949 +0100
0.47.1
Changes since the last tag '0.46.1':
Alberto Fanjul (1):
gtksourceview-2.0: Fix iter parameter in SourceBuffer.backward/forward/...
Arnaud Bonatti (1):
glib-2.0: DateTime.from_iso8601() can take a null TimeZone
Evan Nemerson (1):
libusb-1.0: Use a wrapper for Context.get_device_list()
Florian Brosch (5):
vala: Do not allow += for arrays with fixed length
vala: Infer array length of inline allocated arrays for fields
vala: Do not allow to .resize() on arrays with fixed length
vala: Do not allow to change .length of arrays with fixed length
vala: Improve error message for arrays as type arguments
Michael Gratton (1):
glib-2.0: Add binding for "gettext()"
Ole André Vadla Ravnås (1):
vala: Add missing gmodule-2.0 to Requires.private of pkg-config file
Rico Tzschichholz (157):
sqlite3: Fix use of possibly unassigned parameter `errmsg'
libvaladoc: Include valadoc@PACKAGE_SUFFIX@.deps into tarball
Revert "libvaladoc: Include valadoc@PACKAGE_SUFFIX@.deps into tarball"
valadoc: Explicitly pass --pkg libgvc
gobject-2.0: Some cherry-picking from GIR generated binding
Directly use "memmove()" while g_memmove() is deprecated since 2.40
gio-unix-2.0: Fix DesktopAppInfo.get_string(), UnixFDMessage.steal_fds()
tests: Add "qualified member/symbol access" tests to increase coverage
tests: Add invalid "parser" tests to increase coverage
tests: Extend preprocessor-vala test with VALA_0_46
tests: Extent "post-condition" creation method test to increase coverage
tests: Add "main block" parser test to increase coverage
tests: Add more "invalid expression" tests to increase coverage
vala: Report dedicated error message for params-array parameter mismatch
vala: Output "params" qualifier of parameters
Bump version suffix to 0.48
codegen: Move a bunch of methods to static functions
codegen: Move type-argument checks to SemanticAnalyzer
vala: Warn when directly accessing member of silent cast-expression
vala: Add package_name to missing member error for external MemberAccess
vala: Allow to override virtual interface implementations
vala: Perform stricter compatibility check for delegates
gstreamer: Update from 1.17.0+ git master
gtk4: Update to 3.96.0+bcea9652
gtk4: Constructors of Gtk.MediaFile needs to be static functions
vala: Let methods return an unowned reference to internal collections
vala: Let DataType.get_return_type() return an unowned reference
vala: Return unowned references of internal helper symbols
vala: Rename DataType.data_type property to DataType.type_symbol
codegen: Follow rename of DataType data_type property to type_symbol
valadoc: Follow rename of DataType data_type property to type_symbol
vala: Micro optimizations for SemanticAnalyzer
vala: Micro optimizations for MethodCall
vala: Micro optimizations for MemberAccess
vala: Micro optimizations for Assignment
vala: Unify backing symbol instance of data-types
vala: Move common implementations to CallableType
vala: Drop DelegateType.to_qualified_string() which is duplicated code
vala: Micro optimizations
codegen: Accept children after generating type specific declarations
ccode: Implicitly register declaration for added CCodeFunction
Sync NEWS from 0.46
codegen: Support gobject property of null-terminated array without length
vala: Unify backing symbol instance of data-types (2)
docs: Mention requirement of autoconf-archive as build-dependency
glib-2.0: Set default_value attribute for GLib.pointer
codegen: Preserve full access to delegate variables and its target/destroy cvalues
codegen: Initialize delegate temp-var which is assigned by property getter
codegen: Silence warning about copying if delegate doesn't carry its target
tests: Add dedicated "delegate without target through varargs" test
codegen: Allow passing/retrieving any delegate to/from varargs parameter
codegen: Support gobject property of delegates not carrying their target
vala: Add delegate_target_type and delegate_target_destroy_type to SemanticAnalyzer
vala: Add DelegateType.target/destroy fields to access its user-data
tests: Extend "fastvapi" test to increase coverage
vala: Fix compatible/disposable check between structs and their subtypes
xcb: Fix "missing return statement at end of subroutine body" errors
avahi-client: Fix "use of possibly unassigned parameter" warnings
gnutls: Fix "use of possibly unassigned parameter" warnings
tokyocabinet: Fix deprecation warnings
vala: Don't issue a warning for non-public struct fields in bindings
vapi: Perform syntax and semantic check for all bindings on "make check"
girparser: Add required copy/free attributes for gtype-boxed structs
codegen: Use gtype-boxed API for structs with "g_boxed_free" attribute
Regenerate GIR-based bindings to pick up copy/free attributes
valadoc/tests: Use type for property which is compatible with owned getter
libvaladoc: Fix parameter and property ownership declarations
libvaladoc: Drop unused code
libvaladoc: Remove TypeReference.pass_ownership API
glib-2.0: Guard against passing null source to GLib.Memory.copy()
Sync NEWS from 0.46
libvaladoc: Fix ownership declarations of Constants
parser: `owned` is not allowed on Constants
vala: Replace if-else-tree with switch in UnaryExpression.check()
vala: Replace if-else-tree with switch in BinaryExpression.check()
codegen: Replace if-else-tree with switch in CCodeBaseModule.visit_binary_expression()
vala: Use private argument_list field instead of get_argument_list()
codegen: ErrorType is not a Symbol
tests: Add "wrongly named constructor" tests
glib-2.0: Add new symbols from 2.64
vala: Respect --abi-stability in Class/Interface.accept_children()
vala: Accept interface as inner type for object-type symbols
glib-2.0: Add binding for "warning_once()" since 2.64
gstreamer: Update from 1.17.0+ git master
webkit2gtk-4.0: Update to 2.27.1
vapi: Update GIR-based bindings
girwriter: Restore behaviour for delegate-types
tests: Extent "girwriter" test to increase coverage
codegen: Drop unreachable and misplaced code
tests: Extent "post-condition" virtual method test to increase coverage
tests: Add "default-handler with base-access" signal test to increase coverage
codegen: Use G_TYPE_INSTANCE_GET_INTERFACE to get vtable for base-access
tests: Fix makefile syntax :(
tests: Extend "property base-access" interface test to increase coverage
valadoc: Rename FormalParameter to Parameter
codegen: Reduce code duplications when generation base-access
codegen: Use alternative for g_strcmp0 in POSIX profile
codegen: Replace hardcoded "gboolean" references (POSIX)
codegen: Replace hardcoded "gint"/"int" references (POSIX)
codegen: Replace hardcoded "gpointer" references (POSIX)
codegen: Use alternative for g_free in POSIX profile
codegen: Use alternative for g_new0 in POSIX profile
codegen: Use alternative for g_renew in POSIX profile
codegen: Use alternative for g_memdup in POSIX profile
codegen: Replace specific hardcoded "GDestroyNotify" references (POSIX)
codegen: Make destroy_value() handle array-types in POSIX profile
codegen: Replace specific hardcoded TRUE/FALSE references (POSIX)
codegen: Add required includes or generate used symbols (POSIX)
codegen: Create alternative for G_N_ELEMENTS in POSIX profile
codegen: Correctly transform arguments of Array.resize() for realloc (POSIX)
vala: Allow direct access to array-typed members in POSIX profile
libusb-1.0: Don't depend on glib-2.0
glib-2.0: Add optional "base" parameter to *.parse/try_parse() of integers
glib-2.0: Add (u)int.try_parse()
posix: Bind some essential memory allocation functions
libuse-1.0: Remove unused private "malloc" binding
tests: Make (u)int.try_parse() tests more 32bit friendly
glib-2.0: Check errno for EINVAL and ERANGE in *.try_parse()
girparser: Detect and replace "-" in parameter names
webkit2gtk-4.0: Update to 2.27.2
vapi: Update GIR-based bindings
vala: Issue warning when passing arrays to typeof(), except for "string[]"
tests: Add "typeof" tests for fundamental GLib.Type
tests: Add invalid "silent cast of array" test to increase coverage
linux: Add memfd_create(2)
vala: Don't falsely resolve binary-expression to bool
glib-2.0: Add new symbols from 2.64
gtk+-*.0: Fix iter parameter of TextBuffer.backspace()
codegen: Fix setting of generic-type properties for gobject style chain up
girwriter: Add readable="0"/private="1" attribute to type-specific fields
girwriter: Fix position of priv field (--abi-stability)
codegen: G_DEFINE_AUTOPTR_CLEANUP_FUNC must not declared more than once
vala: Improve error reporting for invalid interface prerequisites
tests: Add invalid "multiple base classes" tests to increase coverage
codegen: Make type-parameter properties readable
vala: Add GenericType.dup/destroy fields
vala: Write value of constants/enums in fast-vapi if they are constant only
vala: Don't mark method as used on recursive usage of itself
gio-2.0: Use custom TaskReadyCallback delegate in Task.report*_error()
g-i: Calculate size correctly, avoid use-after-free
g-i: Avoid use of uninitialized "markup" warning
g-i: Ignore flags like -mfpmath=sse, -msse or -msse2
gtk4,gtk4-unix-print: Update to 3.96.0+fbea677a
vala: Support "unowned var" to declare local variables
libvaladoc: Move gmodule-2.0 to Requires.private of pkg-config file
gstreamer: Update from 1.17.0+ git master
vapi: Update GIR-based bindings
compiler: Add "--list-sources" options to output a list of all sources
vala: Restore DestroysInstance behaviour for non-compact classes
vala: Improve check of delegate assignments and initializers
glib-2.0: Add "has_typedef = false" to custom MarkupParser*Func delegates
vala: Set GLib.Error as symbol of error-types if no error-domain was given
vala: Make Callable derive from Symbol
codegen: Use SemanticAnalyzer.get_data_type_for_symbol()
codegen: Commonize the determining of return-type for delegates and methods
Sync NEWS from 0.46
Release 0.47.1
Simon Werbeck (2):
codegen: Make CCodeBaseModule.generate_method_declaration() return bool
codegen: Fix custom reference-counting for compact classes
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]