[librsvg] Created tag 2.46.2
- From: Federico Mena Quintero <federico src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [librsvg] Created tag 2.46.2
- Date: Mon, 14 Oct 2019 17:03:00 +0000 (UTC)
The signed tag '2.46.2' was created.
Tagger: Federico Mena Quintero <federico gnome org>
Date: 1571072567 -0500
Tag for version 2.46.2
Changes since the last tag '2.46.0':
Federico Mena Quintero (101):
(#506): Fix empty patterns which reference a fallback pattern with children
Start branch explicit-bboxes
Remove the 91-nonzero-translation.svg test
Make stroke_and_fill() return a Result<BoundingBox>
DrawingCtx: remove the bbox field; propagate it through Results
Merge branch 'explicit-bboxes'
Use or_else() to compute fallbacks in gradients/patterns
set_pattern_on_draw_context(): consume the pattern instead of borrowing it
CommonGradient: new struct, a resolved version of CommonGradientData
LinearGradient: resolved version of LinearGradientData
RadialGradient: resolved version of RadialGradientData
CommonGradientData::set_on_cairo_pattern(): rename from set_on_pattern()
Rename PaintSource's associated type Source to Resolved
Move set_pattern_on_draw_context() to a new ResolvedPaintSource trait
Add ResolvedLinearGradient and ResolvedRadialGradient
Implement to_resolved() for NodeFooGradient as a macro
Move the functions which set the gradient on the DrawingCtx to other impls
Specify the resolved gradient type to impl_paint_source!()
impl_paint_source! - use a type, not a token tree, for the gradient
gradient.rs: remove "pub" in a bunch of places
Move the fallback field from CommonGradientData to NodeLinearGradient/NodeRadialGradient
Replace the two gradient nodes with a single NodeGradient
Simplify the while loop in NodeGradient::resolve()
gradient.rs: Don't impl Resolve; do everything directly in the structs
gradient.rs: Rename all the things to make them more consistent and shorter
Add an UnresolvedGradient, and use that instead of temporary clones of NodeGradient
add_color_stops_from_node(): Borrow the child node only once
NodeGradient::resolve(): Rename temporary variables
Inline Common into Gradient
Inline Linear/Radial into Variant
Give a name to the (UnresolvedGradient, next_fallback) tuple
Make resolve_*() not mutate self
Remove NodeStop.get_offset(); access the field directly
Fix tests
Remove superfluous binding
gradient: check the validity of the bbox as late as possible
Remove the bbox argument from PaintSource::resolve()
PaintSource::resolve() - Return a PaintServerError, not a RenderingError
Refactor DrawingCtx::get_clip_in_user_and_object_space()
Make sure we always pass a Some() to get_node_of_type()
DrawingCtx::get_node_of_type(): Take a &Fragment, not Option<&Fragment>
Return Result<Resolved> from resolve(), not Result<Option<Resolved>>
Go back to having NodeLinearGradient and NodeRadialGradient
Add back a Common structure for NodeFooGradient fields
Split off a get_unresolved_variant() function from each gradient type
Compress get_unresolved() with a macro
Cache resolved gradients
Move the resolved field into Common
Document the structs in gradient.rs
Clone the stops directly; don't use a helper clone_stops()
Merge branch 'refactor-gradient'
pattern: set the weak ref on the result, not the long-lived node
Use a strong reference to the pattern's node that has the children to draw
gradient: Ahem, really make resolve_from_fallback() immutable
Comment out RsvgWeakNode; it is unused
gradient: remove the fallback_to! macro now that plain Option.or will do
NodePattern: move the fallback field to the end
gradient: really make resolve_from_defaults() immutable
Make resolve_from_*() take &self, not &mut self
Prepare trait Resolve for immutability later
NodePattern: make fields private
NodePattern: move common fields to a Common struct
pattern: split off an UnresolvedPattern, similar to the gradient code
NodePattern: cache the resolved Pattern
Introduce UnresolvedNodeWithChildren to finally keep track of pattern's children properly
Rename to UnresolvedChildren / Children
Rename PaintServerError to AcquireError
Make get_node_from_type() return a Result, not an Option
Make get_node() return a Result, not an Option
Make get_node_of_type() take a slice of valid types, instead of a single one
Remove the public AcquiredNodes::get_type(); use get_node_of_type() everywhere
Rename get_node_of_type() to just acquire()
Make AcquiredNodes private; use DrawingCtx::acquire_node() everywhere instead
Rename trait and method to AsPaintSource::set_as_paint_source()
Merge branch 'refactor-pattern'
Use the cr.path_extents() from gtk-rs, not an unsafe call.
Use plain Pixbuf::new() now that it detects out-of-memory properly
Move pixbuf_utils to the librsvg_c_api crate
Update NEWS
Bump to version 2.46.1
Cargo update
limits.rs - New file; move the constant for maximum instanced nodes here
Rename num_elements_rendered_through_use to num_elements_acquired
AcquireError: Add a MaxReferencesExceeded variant
Do the limits check in acquire_node()
Propagate AcquireError::MaxReferencesExceeded quickly upstream
Add test for the billion-laughs equivalent from issue #515
xml.rs: Export a single xml_load_from_possibly_compressed_stream() function
XmlState: make a field private
Inline load_from_possibly_compressed_stream() into its single caller
Use a IsA<gio::InputStream> generic only in the toplevel librsvg_crate API
Rename ctx to user_data in the libxml2 callbacks
Use Xml2Parser for the user_data of libxml2 SAX callbacks instead of XmlState
Call xmlStopParser() when the start_element callback returns an error
Use the last error obtained in XmlState as the final result
(#515) - Add a limit for the number of loaded elements
Merge branch 'limits'
Merge remote-tracking branch 'origin/master' into librsvg-2.46
Bump version to 2.46.2
Cargo update
Update NEWS
Jordan Petridis (4):
Allow failures on anything non-opensuse :/
Allow failures on anything non-opensuse :/
COMPILING.md: update fedora deps
rsvg_internals: remove update note from cargo.toml
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]