[libhandy/wip/exalm/paginator-animate: 26/41] carousel-box: Rename child to widget in insert() and reorder()
- From: Adrien Plazas <aplazas src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [libhandy/wip/exalm/paginator-animate: 26/41] carousel-box: Rename child to widget in insert() and reorder()
- Date: Wed, 27 May 2020 15:54:09 +0000 (UTC)
commit 20d10fc4aea0fb4d75de5a4d79be5652ea9a515e
Author: Alexander Mikhaylenko <alexm gnome org>
Date: Thu Dec 26 15:30:26 2019 +0500
carousel-box: Rename child to widget in insert() and reorder()
Avoid a name clash later.
Signed-off-by: Alexander Mikhaylenko <alexm gnome org>
src/hdy-carousel-box-private.h | 4 ++--
src/hdy-carousel-box.c | 30 +++++++++++++++---------------
2 files changed, 17 insertions(+), 17 deletions(-)
---
diff --git a/src/hdy-carousel-box-private.h b/src/hdy-carousel-box-private.h
index 60354f3d..f0de619e 100644
--- a/src/hdy-carousel-box-private.h
+++ b/src/hdy-carousel-box-private.h
@@ -21,10 +21,10 @@ G_DECLARE_FINAL_TYPE (HdyCarouselBox, hdy_carousel_box, HDY, CAROUSEL_BOX, GtkCo
GtkWidget *hdy_carousel_box_new (void);
void hdy_carousel_box_insert (HdyCarouselBox *self,
- GtkWidget *child,
+ GtkWidget *widget,
gint position);
void hdy_carousel_box_reorder (HdyCarouselBox *self,
- GtkWidget *child,
+ GtkWidget *widget,
gint position);
void hdy_carousel_box_animate (HdyCarouselBox *self,
diff --git a/src/hdy-carousel-box.c b/src/hdy-carousel-box.c
index f2202674..13df434e 100644
--- a/src/hdy-carousel-box.c
+++ b/src/hdy-carousel-box.c
@@ -871,44 +871,44 @@ hdy_carousel_box_new (void)
/**
* hdy_carousel_box_insert:
* @self: a #HdyCarouselBox
- * @child: a widget to add
- * @position: the position to insert @child in.
+ * @widget: a widget to add
+ * @position: the position to insert @widget in.
*
- * Inserts @child into @self at position @position.
+ * Inserts @widget into @self at position @position.
*
- * If position is -1, or larger than the number of pages, @child will be
+ * If position is -1, or larger than the number of pages, @widget will be
* appended to the end.
*
* Since: 1.0
*/
void
hdy_carousel_box_insert (HdyCarouselBox *self,
- GtkWidget *child,
+ GtkWidget *widget,
gint position)
{
g_return_if_fail (HDY_IS_CAROUSEL_BOX (self));
- g_return_if_fail (GTK_IS_WIDGET (child));
+ g_return_if_fail (GTK_IS_WIDGET (widget));
- gtk_container_add (GTK_CONTAINER (self), child);
- hdy_carousel_box_reorder (self, child, position);
+ gtk_container_add (GTK_CONTAINER (self), widget);
+ hdy_carousel_box_reorder (self, widget, position);
}
/**
* hdy_carousel_box_reorder:
* @self: a #HdyCarouselBox
- * @child: a widget to add
- * @position: the position to move @child to.
+ * @widget: a widget to add
+ * @position: the position to move @widget to.
*
- * Moves @child into position @position.
+ * Moves @widget into position @position.
*
- * If position is -1, or larger than the number of pages, @child will be moved
+ * If position is -1, or larger than the number of pages, @widget will be moved
* to the end.
*
* Since: 1.0
*/
void
hdy_carousel_box_reorder (HdyCarouselBox *self,
- GtkWidget *child,
+ GtkWidget *widget,
gint position)
{
HdyCarouselBoxChildInfo *info;
@@ -916,9 +916,9 @@ hdy_carousel_box_reorder (HdyCarouselBox *self,
gint old_position, current_page;
g_return_if_fail (HDY_IS_CAROUSEL_BOX (self));
- g_return_if_fail (GTK_IS_WIDGET (child));
+ g_return_if_fail (GTK_IS_WIDGET (widget));
- info = find_child_info (self, child);
+ info = find_child_info (self, widget);
link = g_list_find (self->children, info);
old_position = g_list_position (self->children, link);
self->children = g_list_delete_link (self->children, link);
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]