[retro-gtk] Created tag 1.0.0
- From: Adrien Plazas <aplazas src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [retro-gtk] Created tag 1.0.0
- Date: Sat, 12 Sep 2020 13:05:48 +0000 (UTC)
The unsigned tag '1.0.0' was created.
Tagger: Adrien Plazas <kekun plazas laposte net>
Date: 1599915726 +0200
Version 1.0.0
Changes since the last tag '0.18.1':
Adrien Plazas (46):
core: Use g_object_notify_by_pspec() everywhere
flatpak: Drop useless build options
core: Make it a singleton
core: Document the iterated signal
core: Improve the runahead property documentation
core: Typo, quote and apostrophe fix
core: Fix a precondition in retro_core_override_option_default()
core: Make keyboard_widget_notify() static
core: Make controller_state_changed_cb() static
core: Check controller in retro_core_set_default_controller()
core: Check controller in retro_core_set_controller()
core: Auto emit 'iterated' on cleanup
meson: Don't override retro_gtk_version
Make the D-Bus API clearly private
pixdata: Fix the doc of retro_pixdata_new()
version: Give the doc section a better name and title
log: Link to the signal in the retro_g_log() doc
pixdata: Document the aspect ratio in retro_pixdata_to_pixbuf()
input: Fix %self for @self in doc
controller: Document RetroControllerInterface
Give basic documentation to public sections
cairo-display: Give it some private section documentation
gl-display: Give it some private section documentation
Allow building and installing the reference manual
ci: Build and publish the reference manual
Add HACKING.md
Build enum types with mk-enums
pixel-format: Don't give it a GType
Drop custom enum GType funcs in favor of mk-enum
module: Drop unused variable tmp_file_name
module: Use g_autoptr and fix a few leaks
module: Drop a weird \ character
module: Factorize tmp file destruction
module: Simplify fetching functions
module: Simplify fetching getter methods definition
pa-player: Use g_clear_pointer()
environment: Use g_autofree
core: Use autocleanups
ipc-runner-impl: Use g_autoptr()
gtk: Drop RetroCairoDisplay
pixdata: Drop CAIRO_DISPLAY in a macro name
rumble-effect: Drop the COUNT value
video-filter: Drop the COUNT value
controller-type: Drop the COUNT value
controller-codes: Drop the COUNT values
Version 1.0.0
Alexander Mikhaylenko (80):
Bump API version to 1
retro-core: Don't allow to set non-writable properties
retro-core: Stop constructing the object in new()
retro-controller: Add get_supports_rumble()
retro-controller: Remove poll()
retro-controller: Add 'state-changed' signal
retro-core: Remove return result from message signal
retro-core: Remove return result from shutdown signal
retro-core: Add retro_core_override_option_default()
retro-core: Remove options-set signal
retro-core: Rework state and memory API
retro-main-loop: Merge into RetroCore
retro-core: Don't allow negative speed rate
retro-core-view: Remove an unused function
environment: Return the played samples in on_audio_sample_batch()
retro-core: Use a weak ref for keyboard widget
retro-core: Add missing property getters
meson: Actually use the 'm' dependency
Add RetroMainLoopSource
retro-core: Use RetroMainLoopSource for timing
retro-core: Add 'iterated' signal
retro-core: Add retro_core_get_sample_rate()
retro-pa-player: Bufferize samples on each frame
retro-core: Stop bufferizing samples
meson: Add libsamplerate dependency
retro-pa-player: Resample audio for non-1 speed rates
retro-core: Rename run() to iteration()
retro-core: Rename start() to run()
retro-core: Remove an extra 'iterated' emission
retro-pa-player: Fix resample loop condition
retro-controller-iterator: Mark controller in next() as (transfer none)
retro-controller-iterator: Don't error on null parameters in next()
retro-core: Use GUINT_TO_POINTER() for controller ports
retro-pa-player: Don't try to play audio if there are no samples
retro-core: Make state size mismatch non-fatal
glsl-filters: Re-add bicubic and sharp filters
retro-gl-display: Use shaders for all filters
Create shared/ dir
retro-controller-type: Add functions for getting id and index count
Add RetroMemfd
Add RetroControllerState
Add RetroFramebuffer
Move RetroCore to retro-runner/
Run libretro cores in subprocess
build: Allow to disable pulseaudio
flatpak: Disable pulseaudio for unit tests
ci: Disable pulseaudio for tests
demo: Use dark theme
retro-core: Run a frame when loading state the first time
ci: Make unprivileged
Add a script for running tests locally
retro-core: Iterate earlier in load_state()
retro-core-descriptor: Make 2 functions static
retro-core: Merge retro_core_key_event() into on_key_event()
retro-cairo-display: Normalize draw()
retro-cairo-display: Add a missing blank line
Only use g_return_(val_)if_fail() for public API
retro-framebuffer: Use gfloat instead of float
Stop namespacing static functions unless they are overrides
retro-cairo-display: Drop queue_draw()
retro-gl-display: Drop queue_draw()
Avoid unnecessary casts when connecting to signal
Define signal callbacks with concrete types for user_data
Name all callbacks *_cb()
Use (void) instead of ()
retro-core: Fix adding disk indexes
retro-option-iterator: Add missing gir annotations
retro-core: Handle variables with just one value
core: Replace the previous controller if it already existed
pixel-format: Add retro_pixel_format_to_gl()
retro-framebuffer: Make get_pixels() return gconstpointer
Introduce RetroProcAddress
Introduce RetroHWRenderCallback
Introduce RetroRenderer
retro-framebuffer: Add get_pixels() for runner
Introduce RetroGLRenderer
retro-core: Implement RETRO_ENVIRONMENT_SET_HW_RENDER
Update hardware rendering section in UNIMPLEMENTED.md
gl-renderer: Simplify get_proc_address()
meson: Don't install ipc-runner.c and ipc-runner-private.h
Jordan Petridis (1):
ci: remove deprecated jobs
Neville (3):
Introduce RetroGLSLShader
glsl-filter: Use RetroGLSLShader internally
glsl-filter: Use g_autoptr wherever possible
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]