Naming conventions in GObjects


I am developing GObject Factory, a tool that generates GObjects from
user input.  A problem with naming conventions just popped up.  In my
code I do not seperate words when two capital letters are placed
together in a GObject name (e.g. GMyObject becomes GMY_OBJECT and
gmy_object for macros andd function prefixs respectivly).  Someone
pointed out that the correct output should be g_my_object.  The reason I
do not do this is because objects such as GtkHBox translate correctly to
GTK_HBOX and gtk_hbox so my code covers thoes edge cases.  Which is the
accepted naming convention?  Should all words be broken on capital
letters regaurdless or are there accepted rules for dealing with cases
such as GtkHBox?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]