upgrading toolchain requirements for GNOME 2.4


I've been watching how GNOME 2.0 and 2.2 entered Debian unstable for the
last few months, and I have been annoyed at most GNOME packages failing
to build on some of our arches, due to outdated build tools.

I'm proposing that a few build dependencies are tightened for GNOME 2.4.
The problems come from libtool and automake, mostly. Old versions didn't
support/know about the mips | mipsel architectures for linux-gnu, so
building on these two supported Debian arches failed if we didn't run
"libtoolize" on them prior the package build. This is quite easy to fix,
we just need to ensure GNOME tarballs are created with the correct

For the mips problem, we specifically need:

- libtool version 1.4.3 (any other version didn't have support for mips or
  mipsel). Released on October.
- automake version 1.6 and later. Automake 1.5 and 1.4* didn't have
  support (or had broken support) for mips in config.sub/guess, so they
  should be avoided too. As a general rule, the timestamp in automake's
  config.guess shouldn't be older than 2002 (1.6 was released in March

Is anyone against enforcing these versions for GNOME 2.4 packages?

Please Cc: replies, I'm not on this list.

Jordi Mallach Pérez  --  Debian developer     http://www.debian.org/
jordi sindominio net     jordi debian org     http://www.sindominio.net/
GnuPG public key information available at http://oskuro.net/~jordi/

Attachment: pgpAWOJMzS7kH.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]