[PATCH 00/14] Restructure the _update member of GitBranch
- From: Dirk Wallenstein <halsmit t-online de>
- To: GNOME Desktop Development List <desktop-devel-list gnome org>
- Cc: Frederic Peters <fpeters gnome org>
- Subject: [PATCH 00/14] Restructure the _update member of GitBranch
- Date: Tue, 18 May 2010 13:12:20 +0200
There are a lot of things happening inside _update, and I hope this
series simplifies that a bit. The previous behavior is mostly kept,
except in locations where I thought, that it could be improved:
- Use '--ignore-submodules' to prevent commits in submodules to trigger
a stashing operation.
- (return to a) pull after the branch switch, but ensure a recently
added branch is found when switching
- Fail when there is an attempt to switch dirty branches. Uncommited
changes on the same branch are still moved along.
Dirk Wallenstein (14):
[git] Introduce a predicate execution wrapper
[git] Rewrite the branch name getter
[git] Make git version checks more readable
[git] Use a new predicate to test if a branch tracks a remote branch
[git] Use a new predicate to determine the need to stash
[git] Rename would_be_branch to wanted_branch
[git] Extract the branch switch into a function
[git] Try to find requested branch remotely if not available
[git] Switch branches previous to stash and pull
[git] Extract the pull operation into a function
[git] Move the quiet option to its point of use
[git] Extract sticky date operation into a function
[git] Align local branch predicate with other predicates
[git] Clarify branch switch destination calculation
jhbuild/versioncontrol/git.py | 238 ++++++++++++++++++++++++++---------------
1 files changed, 150 insertions(+), 88 deletions(-)
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]