[evolution-patches] rename inbox/INBOX to Inbox for IMAP
- From: Björn Torkelsson <torkel acc umu se>
- To: evolution-patches <evolution-patches ximian com>
- Subject: [evolution-patches] rename inbox/INBOX to Inbox for IMAP
- Date: Tue, 15 Feb 2005 10:22:12 +0100
As per Not Zed's suggestion, rename the inbox to Inbox to make it
translatable.
For the "old" imap code.
/torkel
? imap/name
Index: imap/ChangeLog
===================================================================
RCS file: /cvs/gnome/evolution-data-server/camel/providers/imap/ChangeLog,v
retrieving revision 1.8
diff -u -r1.8 ChangeLog
--- imap/ChangeLog 9 Feb 2005 17:40:59 -0000 1.8
+++ imap/ChangeLog 15 Feb 2005 09:20:04 -0000
@@ -1,3 +1,9 @@
+2005-02-15 Björn Torkelsson <torkel acc umu se>
+
+ * camel-imap-store.c (imap_build_folder_info): Rename inbox/INBOX to Inbox, so it is
+ translatable.
+ (parse_list_response_as_folder_info): here too.
+
2005-02-08 Jeffrey Stedfast <fejj novell com>
* camel-imap-folder.c (do_copy): Don't always delete the original
Index: imap/camel-imap-store.c
===================================================================
RCS file: /cvs/gnome/evolution-data-server/camel/providers/imap/camel-imap-store.c,v
retrieving revision 1.315
diff -u -r1.315 camel-imap-store.c
--- imap/camel-imap-store.c 4 Feb 2005 03:09:23 -0000 1.315
+++ imap/camel-imap-store.c 15 Feb 2005 09:20:04 -0000
@@ -1015,7 +1015,11 @@
name = fi->full_name;
else
name++;
- fi->name = g_strdup (name);
+ if (!g_ascii_strcasecmp (fi->full_name, "INBOX")) {
+ fi->name = g_strdup (_("Inbox"));
+ } else {
+ fi->name = g_strdup (name);
+ }
return fi;
}
@@ -2418,10 +2422,13 @@
flags = (flags & ~CAMEL_FOLDER_SUBSCRIBED) | (si->info.flags & CAMEL_STORE_FOLDER_INFO_SUBSCRIBED);
fi = g_new0 (CamelFolderInfo, 1);
- fi->name = g_strdup(camel_store_info_name(imap_store->summary, si));
fi->full_name = g_strdup(camel_store_info_path(imap_store->summary, si));
- if (!g_ascii_strcasecmp(fi->full_name, "inbox"))
+ if (!g_ascii_strcasecmp(fi->full_name, "inbox")) {
flags |= CAMEL_FOLDER_SYSTEM|CAMEL_FOLDER_TYPE_INBOX;
+ fi->name = g_strdup (_("Inbox"));
+ } else {
+ fi->name = g_strdup(camel_store_info_name(imap_store->summary, si));
+ }
/* HACK: some servers report noinferiors for all folders (uw-imapd)
We just translate this into nochildren, and let the imap layer enforce
it. See create folder */
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]