Re: libaudiofile compilation on Solaris

> From: Elliot Lee <>
> On 12 Apr 1999, Moya Piernavieja Rodrigo wrote:
> > I am trying to compile libaudiofile on Solaris, but I get this error:
> There has been a newer version available for a while which should fix this
> problem. Please get libaudiofile-0.1.6.tar.gz from your local GNOME
> mirror.

Beware though that though it compiles, libaudiofile has been broken on most RISC 
systems for some time now.  Someone forgot to take into account the different 
endian-ness of Intel Vs. most everyone else when they changed the code, and now 
16bit WAVs (as used by Enlightenment and Gnome) just wont play on Solaris.

You'll get executables, but last I tried compiling the latest libaudiofile into 
esd, esd coredumped when I gave it a 16-bit WAV to play =O(  So I use an even 
earlier one that just about hangs on, but still doesn't play anything.

-------My opinion - Not sane, intelligent or necessarily useful-------
o o                             
/v\ark R. Bowyer.  mailto:Mark.Bowyer@UK.Sun.COM
`-'  "That weenie's avoiding me!" - Scott McNealy about

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]