Let me troll one question (could be added to FAQ):  Why are not the gnome-libs and gnome-core (two only required tarballs) made totally stable, foolproof installed before distribution?  It seems somebody doesn't give a shit about his software?  Pointless to extend/develop software based on unstable foundation libraries?  It is impossible for me to even install gnome infrastructure, at this moment.

Out of sheer frustration, I'm going to relate my install experience with gnome.  I will eventually do backtraces, and debug the crap, but I first want to know if anyone knows about or has solved these problems before I start trying to figure them out, because I got pissed off and deleted every gnome-related file I can find, after about two days and 18 hours of installing, and now I have to re-d/l all the stuff and reinstall.  

I can debug, just tell me if there exist already solutions so I don't have to waste my time.  Please log  some of this stuff as bugs, or don't.  

I do not believe --prefix=/usr/local/gnome is propogating correctly.  This is because none of the gnome-specific libraries can be found there by gnome-core during make.

kernel 2.0.35
gtk/glib 1.2.0
libc5 (slackware 3.2)
See attached file "l" for installed libs.  They are all current, up-to-date.
	All additional libraries in their default install directories.  Only gnome-specific stuff configured with --prefix=/usr/local/gnome (i.e. gnome-libs, gnome-core, and that's how far I got).

(Note, I'm tired, and I may have libgtop/libgr reversed in this next note:)
FAQ bug:
libgtop depends on gnome-libs, but gnome-core depends on libgtop, so the correct install order is:
1) gnome-libs
2) libgtop
3) gnome-core

Also note, there are compile problems with libgr (libgtop(?), the one with all the image libraries in it).  Specifically, png does not compile.  None of it installs, every single directory fails with, for example:
libpng.a  no such command
Apparently make is trying to execute libpng.a in the makefile.

Compiles.  Gnome-libs can't find it when libraries installed, ran ldconfig

Had to hack it to get it to compile  (sent note to esr).  Didn't bother installing it, figured I'd make life easy and use --disable-nls

configure --prefix=/usr/local/gnome --disable-nls
make fails in gnome-data dir.  Execution of command in makefile:
gnome-gen-mimedb /usr/local/gnome/etc/mime-magic  (I've replaced the variables with the actual file names.  --->segmentation fault.
I found the wrapper in ../libgnome/  It pointed to a program:

So I edited the source /libgnome/.libs/gnome-gen-mimedb.c  and added, directly in main after the variable declarations this function:
printf("Starting mimed b program...\n");
Program once again Seg faults.  I loaded the binary in .libs to make sure my string was compiled in.  It was.

I found one posting in comp.os.linux.x with the exact same problem.

By the way, in /gnome-data/Makefile the line for install:  chgrp (GAMES_(?)) fails.  "games" is not a valid group.
# commented out the line in makefile to skip gnome-gen-mimedb, gnome-libs installs.

configure --prefix-/usr/local/gnome --disable-nls

I had a lot more configure options, mostly realted to libgr (or was it libgtop(?)) so that the five or so applications would be built.  Configure could not find the libgtop-config file.  I had to hack configure all to hell, deleting the else from the if/fi (about line 6070, 6170) and manually typing in /usr/local/gnome/bin/libgtop-config and so on, because configure could not find the libgtop-1.0.0 library or executalbes.  And yes, I tried several --with-libgtop --with-libgtop-exec but none of it worked/recognized.

make failure in /gnome-terminal.   Seems during linking, there are undefined references to
zvt_*.  Seems it can't find the libraries.  Since we are linking object files, and I know damn well that libraries are available (ldconfig -p), I assume the compiler can't find the libraries.  
The libraries are in /usr/local/gnome/lib/   but this does not seem to propogate.  

Hey, figured I can skip the terminal, just run xterm.  Make fails again at /panel.   The orb/Orbit libraries are not being found.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]