Re: RPM's are bad

Making compatibility rpm-s is certainly the case for stable base libraries.
But all pre 1.4 gnome-print versions are considered unstable, so it seems
to be a bad idea, to make compatibility packages for them. But of course,
if somebody wants to mess, he can do that.
Hopefully the situation will be cleared with gnome-1.4 release.
Lauris Kaplinski
> > >A harder problems is that we would like to have packages that can be
> > >installed with different versions in the same time. I have gnome-print
> > >0.20 installed and I have other packages that needs
> > >/usr/lib/ So now I cant upgrade to gnome-print-0.24 and
> > >therefore I cant use newer programs that needs 0.24.
> > 
> > This is an unavoidable problem.  When API's change, bumping library version
> > numbers is the right thing to do.  Distributions sort this out for you.
> Sure, but shouldn't we try to create packages that you can choose to keep
> installed so that old programs still works. For some packages people have
> created new rpm's that allow that. For example there is gtk+10 packages
> for those who have installed gtk+ version 1.2. And I guess that when gtk+
> version 2.0 comes someone will create gtk+12 packages. Why not create
> packages that we can keep in the first place.
> If we look at gtk+ as an example we se that there is even more
> problems. The gtk+10 package does not contain the locale files. Then are
> named for example /usr/share/locale/sv/LC_MESSAGES/ I guess that
> old programs that still uses gtk+1.0 will use the new .po files which
> might not be a good idea..

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]