Re: FAM: FAMOpen(3X) fails but cause is not shown

Dixit Benoit Dejean (2004-05-29 10:29):
> >I have a Fedora Core 2 system with fam-2.6.10-9 and portmap-4.0-59.
> i have a Debian sid and libfam version is 2.7.0-5. Your example works
> without any error. i think you should upgrade your libfam.

After I read your reply, I compiled fam 2.6.10 from the sources I
got on and tried my program again.

This time it worked.  What is interesting is the difference in
the shared libraries that are required.  Normally, 'ldd a.out'
reports this: =>  (0x00537000) => /usr/lib/ (0x003e1000) => /lib/tls/ (0x00771000) => /lib/ (0x00c90000)
        /lib/ => /lib/ (0x00a57000)

When LD_LIBRARY_PATH=/opt/local/fam-2.6.10/lib, the same command
says this: =>  (0x00d99000) => /opt/local/fam-2.6.10/lib/ (0x0084d000) => /lib/tls/ (0x0022b000) => /usr/lib/ (0x00111000) => /lib/ (0x001ca000)
        /lib/ => /lib/ (0x0034b000) => /lib/tls/ (0x003ef000)

I notice the disappearance of  I guess I'll have
to go to some Fedora lists to try to sort this out.  Thanks for
your reply.

Pierre Sarrazin <sarrazip at sympatico dot ca>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]