Re: gnome-common CVS can't find automake

kevlinux wrote:

I've been trying for a few days now to compile the latest PAN CVS
commits.  I get the following, and it was suggested to try this list.

First, proof automake is there:

bash-2.05b$ which automake

bash-2.05b$ automake --version
automake (GNU automake) 1.8.4
Written by Tom Tromey <tromey redhat com>

Now, the attempt at

bash-2.05b$ ./
checking for autoconf >= 2.53...
 testing autoconf2.50... not found.
 testing autoconf... found 2.59
checking for automake >= 1.4...
 testing automake-1.4... not found.
***Error***: You must have automake >= 1.4 installed
 to build Pan.  Download the appropriate package for
 from your distribution or get the source tarball at

I've updated PAN CVS, and gnome-common CVS and still get the same
errors.  Any ideas?
To build Gnome, you should ideally install Automake 1.4-p6, 1.7.9, 1.8.5 and 1.9.x (in that order, so the /usr/bin/automake symlink points at the newest automake).

Since there was such a large difference between automake-1.4 and 1.5, gnome-common won't use a modern automake version unless the package specifically asks for it (this was done to not break existing packages -- ideally all packages should specify their minimum required automake version now). For Automake versions > 1.4, it will fall back to other minor version series.

Of course, if you are building Gnome from CVS, I'd recommend you look at a tool like jhbuild, which will take care of a lot of the details for you (like working out what order to build things in).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]