Re: GTkClist Patch Submission (modified)



On Mon, Jul 31, 2000 at 12:51:38PM -0500, Matthew wrote:
> @@ -5105,6 +5105,15 @@
>        {
>         gpointer drag_data;
>  
> +        if (event->type==GDK_2BUTTON_PRESS) {
> +         gint width;
> +          width = gtk_clist_optimal_column_width (clist, i);
> +         gtk_clist_set_column_width (clist, i, width);
> +         clist->freeze_count=8;
> +         return FALSE;
> +        }

Magic numbers, such as "8", should not acceptable in any project.

(Disclaimer: I'm not a GTK developer.)

-- 
Evan Martin - eeyem@u.washington.edu - http://students.washington.edu/eeyem




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]