Re: pending stuff in havoc-patches



Havoc Pennington <hp@redhat.com> writes:

> Hi,
> 
> I left out the progress bar changes; for those, I'm waiting to hear
> back about the "refresh" signal, see this post:
>   http://www.gnome.org/mailing-lists/archives/gtk-devel-list/2000-March/0225.shtml
> 
> So, please give me an answer on that and I'll merge the progress bar stuff.

IMO, it doesn't make sense to add a 

 GtkProgressBar::refresh (GtkProgressBar *progress, gfloat fraction, gboolean activity_mode)

thing unless you wanted to allow derivation from GtkProgressBar for creating new
types of progress-thingies. But I wouldn't want to add that capability until
we removed GtkProgress.

That is, the idea was:
 
                               GtkProgress
                              /           \
                    GtkProgressBar     GtkProgressSpiral

I don't think that this is very useful - basically, the abstraction isn't worth
the complexity once you make things as simple the new GtkProgress; you can
simply duplicate the API in "GtkProgressSpiral", if you really want to write
one.

But, in any case, while I could accept:

                             GtkProgressBar 
                                    |
                             GtkProgressSpiral

I do not want to see:

                              GtkProgress
                                    | 
                             GtkProgressBar 
                                    |
                             GtkProgressSpiral

So, a GtkProgressBar::refresh() doesn't make sense to me currently. Why don't
we just keep things simple for now, and in the future we can hopefully
remove enough of the old API to make it reasonable to redo it in a different way.

Regards,
                                        Owen





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]