Status of 2.0 API freeze bugs



We currently have 36 open '2.0 API freeze' bugs. These will presumably
still be open after we put out 1.3.3 tomorrow, which we've intended
to be the pre-guadec api-freeze candidate.

(Note that as of last week, the count was about 65, so we've made 
good progress.)

Here's my recommendations about which of these bugs we should slip
in past 1.3.3, and which ones to not do for 2.0.0, or to not
do at all.

As it happens, the split is 50/50 - 18 to do for GTK+-2.0, 18 not to do.
Most of few of the ones to do are trivial - applying existing patches,
and so forth. I'm hopefully we should be able to get these all
cleared up within, say, 2 weeks.

Regards,
                                        Owen

Slip past GUADEC
================

1579	general	gtk+	Setting Gtk widget insensitive can lock GUI 

 Was mostly fixed in GTK+-1.2; probably can be fixed by combination
 of documentation and porting that.

50089	gobject	glib	g_signal_handler_disconnect_matched too hard 

 Few outstanding naming issues, question of whether to add
 disconnect_by_data().

50205	gobject	glib	GCallback should not be a void pointer 

 Needs to be done.

50209	gobject glib	Need a G_TYPE_ for non-nul-terminated strings 

 Patch from otaylor needs to be fixed-up / applied by timj

50213	gobject glib	No accessor for GObject::property_specs 

 Some debate on how this should behave exactly, but clearly needed.

50215	gobject glib	g_param_spec_string_c is a very cryptic function name 
 
 Simple rename to g_param_spec_identifier or removal.

50218	gobject glib	Notification on write-only properties is questionable/proble 
 
 This is not really API - just a question of either ignoring or warning
 in this case.

50902	gtk 	gtk+	GTK+ Widgets need to implement an Accessibility API 

 Very important GNOME 2 release goal. Details to be discussed at GUADEC.

50919	gtk 	gtk+	Finish Plug/Socket 

 API changes are trivial (or non-existant), still a lot of work in 
 the guts.

50966	gobject	glib	Interface methods can't be overridden in derived classes 
 timj working on it; very important to get in.

51063	gobject	glib	Weak references 
 
 Various open questions, probably needs to be discussed at guadec.
 Final API changes should be pure additions and simple.

51745	gtk	gtk+	Notification of accelerator changes 

 timj apparently working on it.

51746	gtk	gtk+	Notification of shadowing by gtk_grab_add 

 patch from otaylor exists, probably should just be applied.

51748	gobject	glib	Need way of overriding default values for properties 

 timj apparently working on it.

50212	gobject	glib	Copying param information is not necessary 
 
 Waiting on profiling data once we get all property patches applied

52434	gtk	gtk+	Lock accelerators by default 

 timj apparently working on it. Not clear what the API changes will
 be but they should be simple. (Also, patch from otaylor exists.)

52453	TextVw	gtk+	first/end naming in GtkTextBuffer 

 s/first/start/ needs to be done ASAP. It's basically mechanical, but 
 touches a lot of code.

52811	general	glib	Need encoding conversion for GIOChannel

 Quite important for actually using GTK+-2.0. Already have a
 good portion of an implementation. However, there is some question if 
 we have sufficient time to get the right API.


Do after 2.0
============

50080	gdk-pix	gtk+	gdk_pixbuf_get_from_drawable() is hosed 

 There are serious implementation bugs here that need to be fixed post API
 freeze, but I think the API additions here can be punted.

50768	general	gtk+	Make the input widget's cursor Xkb keyboard layout aware 

 The API additions are tiny (a ::direction_changed signal on the KB map
 object), but the feature can be done without if necessary.

50972	gobject	glib	g_enum_get_value_name() 
 
 A lot of disagreement about how to do this

50980	gdk-pb	gtk+	revamp inlined pixbuf code 

51731	gtk 	gtk+	Add an INACTIVE state 
51747	gtk	gtk+	Rethink GtkStateType 

 Sigh. Too much work to get done at this point. A GTK+-3.0 thing,
 probably.

52179	TextVw	gtk+	Relative font sizes for text widget 

 Pretty easy, important, but can be added compatibly in the future.

52574	gtk	gtk+	geometry parsing 

 Can be added compatibly in the future.

Don't do
========

50070	TreeVw	gtk+	DND in TreeView needs implementing 

 May be finished? Needs testing.

50266	TreeVw	gtk+	Text/Pixbuf/Pixtext cell renderers could just be merged 
 Would be better, most likely. But I don't think jrb really agrees,
 and nobody feels strongly.

50837	gtk	gtk+	GtkPaned patch 

 There are serious questions about the quantum stuff in here. The 
 hiding-the-separator-when-one-side-is-invisible part is probably
 right, but would be easier done from scratch.
 
50936	gtk	gtk+	nonlinear mappings for GtkRange widgets 

 We think this should just be done as GtkSpinButton style ::output
 signal.

51174	gtk	gtk+	GtkColorSelection API is screwed up 

 Most of the effect probably could be done fairly easily, though
 color 

50206	gobject	glib	Some GObject methods take a gpointer 

 AFAIK, no response from timj on this one. Ugly/inconsistent the
 way it is now, but most people probably won't notice.

52027	gtk	gtk+	Expose gtk_rc_style_find(name) 

 A gtk_style_get_from_path() or suchlike would be useful, but
 timj and otaylor agree that retrieving RC styles by name is the
 wrong thing to do.

50211	gobject	glib	would be nice to get rid of g_type_init() 

 Would still at least like get rid of the GDebugFlags argument...




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]