Re: GtkNotebook accelerators.
- From: Alexander Larsson <alla lysator liu se>
- To: Ryan Lovett <ryan OCF Berkeley EDU>
- Cc: <gtk-devel-list gnome org>
- Subject: Re: GtkNotebook accelerators.
- Date: Tue, 27 Feb 2001 15:28:07 +0100 (CET)
On Mon, 26 Feb 2001, Ryan Lovett wrote:
> Hi,
> Perphaps 's/page_label/page_with_label/' ? There's a precedence:
>
> spacecoaster:/usr/include/gtk-1.2/gtk> grep with_label *
> gtkbutton.h:GtkWidget* gtk_button_new_with_label (const gchar *label);
> gtkcheckbutton.h:GtkWidget* gtk_check_button_new_with_label (const gchar *label);
> gtkcheckmenuitem.h:GtkWidget* gtk_check_menu_item_new_with_label (const gchar *label);
> gtklistitem.h:GtkWidget* gtk_list_item_new_with_label (const gchar *label);
> gtkmenuitem.h:GtkWidget* gtk_menu_item_new_with_label (const gchar *label);
> gtkradiobutton.h:GtkWidget* gtk_radio_button_new_with_label (GSList *group,
> gtkradiobutton.h:GtkWidget* gtk_radio_button_new_with_label_from_widget (GtkRadioButton *group,
> gtkradiomenuitem.h:GtkWidget* gtk_radio_menu_item_new_with_label (GSList *group,
> gtktogglebutton.h:GtkWidget* gtk_toggle_button_new_with_label (const gchar *label);
> gtktreeitem.h:GtkWidget* gtk_tree_item_new_with_label (const gchar *label);
>
>
> Just my half a cent,
> Ryan
Well. Those are all new_with_label, which is sorta different. If you call
only .._new() you need to create and insert your own child in the widget.
Comparing gtk_notebook_prepend_page() and gtk_notebook_prepend_page_label()
the only difference is that the first takes a GtkWidget label argument and
the last a gchar * label argument.
gtk_notebook_prepend_page_text() or something might be better though.
I'm waiting for comments from the maintainers.
/ Alex
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]