Re: gtk_message_dialog_new_with_markup() revisited
- From: Owen Taylor <otaylor redhat com>
- To: Noah Levitt <nlevitt columbia edu>
- Cc: Matthias Clasen <maclas gmx de>, gtk-devel-list gnome org
- Subject: Re: gtk_message_dialog_new_with_markup() revisited
- Date: Wed, 13 Aug 2003 11:15:17 -0400
On Wed, 2003-08-13 at 10:57, Noah Levitt wrote:
> My feeling is that passing markup into the format string is
> hokey and somewhat difficult to follow. And, people can
> achieve the same thing with two extra lines of code the old
> fashioned way (g_strdup_printf). So I don't think we should
> bother supporting it here.
I'd tend to agree, except that the two lines of extra
code wouldn't work, because gtk_messag_dialog_new_with_markup()
is currently the only way (other than accessing private struct
fields) to set markup on a message dialog, and neither:
gtk_messag_dialog_new_with_markup(dialog, ..., markup_string);
gtk_messag_dialog_new_with_markup(dialog, ..., "%s", markup_string);
Will work - one is vulnerable to embedded %s, the other
escapes.
That's why I suggested we might want to add a
gtk_messag_dialog_set_markup() that took a fixed string,
like gtk_label_set_markup().
Regards,
Owen
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]