Re: [patch] gnome_desktop_item_new_from_string



Hi Darin,

On Wed, 20 Feb 2002, Darin Adler wrote:

> Here's a patch to add the call I need for Nautilus.
> I also fixed some bugs I found.
> Is this the right list to send it to?
>
> May I commit?

	Yes, looks fine apart from the two minor comments below.

	Also, you've quite a few string changes in there, could you
either kill the changes or go through the proccess with the release
team of getting them approved?

Cheers,
Mark.

> +static ReadBuf *
> +readbuf_new_from_string (const char *uri, const char *string, gssize length)
> +{
> +	ReadBuf *rb;
> +
> +	g_return_val_if_fail (string != NULL, NULL);
> +	g_return_val_if_fail (length >= 0, NULL);
> +
> +	rb = g_new0 (ReadBuf, 1);
> +	rb->uri = g_strdup (uri);
> +	rb->buf = (char *) string;
> +	rb->size = length;

	could you add rb->buf_needs_free = FALSE for clarity?

> +	retval = ditem_load (rb,
> +			     (flags & GNOME_DESKTOP_ITEM_LOAD_NO_TRANSLATIONS) != 0,
> +			     error);
> +
> +        if (retval == NULL) {
> +		return NULL;
> +	}
> +
> +	/* FIXME: Sort order? */
> +
> +        return retval;
> +}

	your indentation has gone a bit wonky here :)





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]