Re(2): __register_frame_info again

> Last night I did what was told on the list. That is, create a and 'export LD_PRELOAD=/usr/local/lib/'. Then I went to compile gnome-db and everything was ok, but I then tried to compile gimp (not latest CVS one) and I got the following error:
> undefined reference to __register_frame_info
> If one compilation works why the other one does not? (GNOME-DB also links to GTK+)

>try make clean, you eventually have some od object files floating around,
>compiled with a different compiler version.

That did not work. I did a make distclean, sh -x and make, and I got the same error. My question is: I had the same RPMS I've got now in the same system before reinstallation (of all the system, not GNOME) and I did not get this error, and I did not install any package outside from my RedHat CD (well I did, but none related to libc), so I guess the missing library is on my RedHat CD. I've got gcc and egcs both installed on my system, so what should I do, reinstall egcs forcing it to write the libc file? get a newer egcs version?

Please HELP!!!!!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]