Re: anoncvs failures

On Fri, 13 Aug 1999, Tomas Ogren wrote:

> On 12 August, 1999 - James Green sent me these 1,4K bytes:
> > > cvs server: failed to create lock directory in repository `/cvs/gnome/audiofile': Permission denied
> > > cvs server: failed to obtain dir lock in repository `/cvs/gnome/audiofile'
> > > cvs [server aborted]: read lock failed - giving up
> > > 
> > > Note that my CVS get script retries 5 times, so this is not just a
> > > failure on a single mirror; it's happening on all of them.
> > 
> > How does it detect failure and try again?
> > 
> > And I concur that this isn't just VA's broken machine - it's them all (I
> > guess).
> I run, which is one of the anoncvs machines. I just
> tried doing a fresh checkout out the entire gnome module. All works
> fine.
> Also, I don't see any error message from the rsync log which currently
> spans 2 weeks back.


Just done some testing. It seems that if CVSROOT is, the
errors leap up. This however fixes it:

[jg@cyberstorm gnome]$ export
[jg@cyberstorm gnome]$ cvs login
(Logging in to
CVS password:
[jg@cyberstorm gnome]$ cvs -z3 update -Pd gnome-libs
? gnome-libs/libvfs
cvs server: Updating gnome-libs
[ etc ]

So, something's up with the handling of in cvs I guess.
I don't know what, I'm a complete novice at cvs. Using cvs-1.10.5-2.

I tried update four times with the same result. My
machine does not cache dns.

James Green
Home of the 56k FAQ.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]