Re: About gnome-libs compilation

Sun Oct 17 1999, Antonio Beamud Montero ->
> Hello:
>  I have download glib, gtk+, imlib, ORBit, gnome-libs, gnome-core from
>  anoncvs, and I have compiled glib, gtk+, imlib, ORBit without
>  problems, but when I have tried to compile gnome-libs
>  (gnome-libs-1-0) the next error appears:
> checking for pthread_create in -lpthread... yes
> checking for gtk-config... /usr/local/bin/gtk-config
> checking for GTK - version >= 1.2.0... no
> *** Could not run GTK test program, checking why...
> *** The test program failed to compile or link. See the file config.log for the
> *** exact error that occured. This usually means GTK was incorrectly installed
> *** or that you have moved GTK since it was installed. In the latter case, you
> *** may want to edit the gtk-config script: /usr/local/bin/gtk-config
> configure: error: GTK not installed
>  When I execute gtk-config --version it reports me:
>  1.3.0 (unstable)
>  Then, why doesn't works? I need version 1.2.x (stable) of gtk+? 
>  (All is under /usr/local).

What errors does configure report? (Look in config.log as the error
message says.)
Have you tried doing ldconfig? The gtk test can fail if the libraries
are not found. The test can also fail for a lot of other reasons.
config.log should give you the answer.

If you want the stable version of gtk from cvs then do
cvs checkout -r gtk-1-2 gtk+


[ ] [ PGP: 0x453504F1 ] [ UIN: 4439498 ]
    Opinions expressed above are mine, and not those of my future employees.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]