Re: GConf problems

  BTW, the backtrace is

#0  0x405f96b2 in sigsuspend ()
#1  0x40485703 in   ()
#2  0x4048306a in   ()
#3  0x4026b0d7 in gdk_event_prepare (source_data=0x0,
    timeout=0xbfffd548, user_data=0x0) at gdkevents.c:2066
#4  0x403a7758 in g_main_iterate (block=1, dispatch=1) at gmain.c:771
#5  0x403a7c11 in g_main_run (loop=0x818cc28) at gmain.c:935
#6  0x406c2c7d in oaf_server_by_forking (cmd=0x406c6440, ior_fd=123, 
    ev=0xbfffe0b0) at oaf-registration.c:301
#7  0x406c11c5 in local_activator (regcat=0xbfffe0e0, cmd=0x406c6440, 
    ior_fd=123, ev=0xbfffe0b0) at oaf-mainloop.c:255
#8  0x406c30b8 in oaf_activators_use (regcat=0xbfffe0e0, cmd=0x406c6440, 
    ior_fd=123, ev=0xbfffe0b0) at oaf-registration.c:464
#9  0x406c3207 in oaf_service_get (regcat=0xbfffe0e0) at
#10 0x406c0fa1 in oaf_activation_context_get () at oaf-mainloop.c:137
#11 0x406c2545 in oaf_activate_from_id (
    aid=0x404b7288 "OAFAID:[OAFIID:gconfd:19991118]", flags=4,
    ev=0xbfffe158) at oaf-activate.c:122
#12 0x404a27b1 in try_to_contact_server (start_if_not_found=0, err=0x0)
---Type <return> to continue, or q <return> to quit---
    at gconf.c:1438
#13 0x404a2911 in gconf_get_config_server (start_if_not_found=0, err=0x0)
    at gconf.c:1488
#14 0x404a0999 in gconf_engine_unref (conf=0x80f63d8) at gconf.c:314
#15 0x404bd70d in gconf_client_finalize (object=0x80c1cf0)
    at gconf-client.c:268
#16 0x401d35e1 in gtk_object_unref (object=0x80c1cf0) at gtkobject.c:1194

<there's more, but the rest is not important>

On Tue, 18 Apr 2000, Gustavo Joćo Alves Marques Carneiro wrote:

>   Hi.  I'm trying to use GConf.  It seems to be working well except when
> my program tries to destroy de GConfClient object.  Then, the program
> halts with the message:
> 	Trying dir /home/ee96090/opt/gnome//share/oaf
>   (/home/ee96090/opt/gnome/ is the prefix where it (and all gnome) is
> installed)
>   When I run gconfd& in background before running my program, this doesn't
> happen.  Also, I run gconfd& instead of gconfd because sometimes gconfd
> doesn't exit -- it hangs.
>   Can anyone help me? Thanks!

Gustavo J. A. M. Carneiro

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]