Re: libpng versioning problems making RPMS incompatible across Linux's



On 27 August, 2000 - Paul Sheer sent me these 2.5K bytes:

> 
> 
> Hi there
> 
> libpng.so.2.1.0.6 is not compatible with libpng.so.2.1.0.8
> it seems.
> 
> If I use 2.1.0.6 then my Gnome apps SEGFAULT. If I use
> 2.1.0.8 then my KDE apps segfault.
> 
> Shouldn't version numbering sort out this? Is it a problem
> with libpng versioning?

Screwup by the libpng maintainers. 1.0.7 introduced an additional item
in a struct causing binary incompability. But I thought 1.0.8 fixed
that.. hrm.

/Tomas
-- 
Tomas ÷gren, stric@ing.umu.se, http://www.ing.umu.se/~stric/
|- Student at Computing Science, University of UmeŚ
`- Sysadmin at {cs,ing,acc}.umu.se





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]