Re: Running remote Gnome programs - problems with SSH

On Thu, 21 Sep 2000, Graham Leggett wrote:

> Hi all,
> I am having some trouble running some remote Gnome programs on another
> machine.
> - I run a Gnome desktop on my local machine.
> - I SSH to a remote machine. X11 connections are forwarded.
> - I run gnomecc (for example):
> [10:58am] bcngrle dsnstar:~> gnomecc
> ** WARNING **: Could not get name service!
> ** ERROR **: file goad.c: line 1237 (goad_server_register): assertion
> failed: (name_server != CORBA_OBJECT_NIL)
> aborting...
> Abort
> Exit 134
> - I try to start the name service manually:
> [10:59am] bcngrle dsnstar:~> gnome-name-service	
> Exit 1
> - There is another user using a remote Gnome session on the box already,
> the difference is that I am running a Gnome session locally on my
> machine, while they are not. Apps work for them, they don't for me.
> - The username on my local machine and my username on the remote
> emachine are not the same. Should this cause trouble?
> - Normal X progams (like Netscape) work fine.
> - Some simple Gnome programs work fine, more complex ones (like gnomecc)
> do not.
> Does anyone have an idea what the "could not get name service" message
> is trying to tell me (apart from the obvious "there is no name service",
> rather than the more useful "why")?

It is the programs that use CORBA that are causing trouble for you.  Do
you have a firewall or something between the X client and server
machines?  If so, then this is probably blocking the CORBA connections.  I
don't know how easy it would be to get an ssh tunnel set up, as a
number of random ports would be used and you would also need to munge IORs
for a different IP address.


Email: james daa com au

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]