Running remote Gnome programs - problems with SSH

Hi all,

I am having some trouble running some remote Gnome programs on another

- I run a Gnome desktop on my local machine.
- I SSH to a remote machine. X11 connections are forwarded.
- I run gnomecc (for example):

[10:58am] bcngrle dsnstar:~> gnomecc

** WARNING **: Could not get name service!

** ERROR **: file goad.c: line 1237 (goad_server_register): assertion
failed: (name_server != CORBA_OBJECT_NIL)
Exit 134

- I try to start the name service manually:

[10:59am] bcngrle dsnstar:~> gnome-name-service	
Exit 1

- There is another user using a remote Gnome session on the box already,
the difference is that I am running a Gnome session locally on my
machine, while they are not. Apps work for them, they don't for me.

- The username on my local machine and my username on the remote
emachine are not the same. Should this cause trouble?

- Normal X progams (like Netscape) work fine.

- Some simple Gnome programs work fine, more complex ones (like gnomecc)
do not.

Does anyone have an idea what the "could not get name service" message
is trying to tell me (apart from the obvious "there is no name service",
rather than the more useful "why")?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]