building from sources troubles

When trying to compile the control-center (version 1.2.3) code I get the
following error:

gcc -g -O2 -Wall -Wunused -o .libs/theme-selector-capplet
../../control-center/.libs/ -L/usr/lib -lORBitCosNaming
-lORBit -lIIOP -lORBitutil -lglib -lm -lm -ldl -L/usr/X11R6/lib -lgnorba
-lORBitCosNaming -lORBit -lIIOP -lORBitutil -lgnomeui -lart_lgpl
-lgdk_imlib -lSM -lICE -lgtk -lgdk -lgmodule -lXext -lX11 -lgnome
-lgnomesupport -lesd -laudiofile -lm -ldb-3 -lglib -ldl -L/usr/lib
-lImlib -ljpeg -ltiff -lpng -lz -lm -lXext -L/usr/X11R6/lib -lSM -lICE
-lXext -lX11 file.o globals.o lister.o main.o signals.o demo.o gui.o
install.o ../../control-center/.libs/ -lORBitCosNaming
-lORBit -lIIOP -lORBitutil -lglib -lm -lm -ldl -lgnorba -lORBitCosNaming
-lORBit -lIIOP -lORBitutil -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE
-lgtk -lgdk -lgmodule -lXext -lX11 -lgnome -lgnomesupport -lesd
-laudiofile -lm -ldb-3 -lglib -ldl -rdynamic -L/usr/lib -L/usr/X11R6/lib
-L/usr/lib -lORBitCosNaming -lORBit -lIIOP -lORBitutil -lglib -lm
-rdynamic -lgnomeui -lart_lgpl -lgdk_imlib -lSM -lICE -lgtk -lgdk
-lgmodule -lXext -lX11 -lgnome -lgnomesupport -lesd -laudiofile -lm
-ldb-3 -lglib -ldl -lImlib -rdynamic -lgtkxmhtml -ljpeg -lpng -lz -lSM
-lICE -lgtk -lgdk -lgmodule -lglib -ldl -lXext -lX11 -lm -lgnorba
/usr/lib/ undefined reference to
/usr/lib/ undefined reference to `XpmFreeXpmInfo'
/usr/lib/ undefined reference to `XpmGetErrorString'
/usr/lib/ undefined reference to
/usr/lib/ undefined reference to `XpmFreeXpmImage'
collect2: ld returned 1 exit status
make[3]: *** [theme-selector-capplet] Error 1

looking at gtkxmhtml I have to say the linker is not lying:

->nm -Bg /usr/lib/ | grep XpmCreateXpmImageFromBuffer
        U XpmCreateXpmImageFromBuffer

This points me to the gnome-libs package, I am using 1.2.11. When
configuring the libs I noticed the following:

checking for XpmFreeXpmImage in -lXpm... no

but this is not true:
->nm -Bg /usr/X11R6/lib/ | grep XpmFreeXpmImage
0000c45c T XpmFreeXpmImage

and /usr/X11R6/lib is in the loader path

->at /etc/
# Begin /etc/


# End /etc/

Another thing I noticed is that I get the following:

checking for perl5... no


->perl -v

This is perl, v5.6.0 built for i686-linux

Does anyone have any idea what could be going on here? What can I do to
make this work? I am trying to build a Linux system from scratch and
would really like to run GNOME on it.

As a trick I added -lXpm to the link flags in the Makefile og
gtk-xmhtml, rebuild the libraries and then tried the control-center, but
that didn't get me anywhere either. As I got an unresolved symbol in Xpm
"_fxstat" not that I know what this means either.

I also tried the 1.2.3 version og the libs package with no success.

Any help is appreciated.


Robert Schweikert                      MAY THE SOURCE BE WITH YOU
rjschwei mindspring com                         LINUX

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]