Missing autoconf macro (or something) please help


I'm trying to get my configure.in and makefile.am files for a package to
compile under GNOME right using the example in the "GTK+/GNOME Application Development" book.  When I run my autoconf.sh I get
moaned at by automake and configure.  I get these messages:


Makefile.am : variable GNOMEUI_LIBS not defined
Makefile.am : variable GNOME_LIBDIR not defined


./configure: GNOME_INIT: command not found
./configure: GNOME_COMPILE_WARNINGS: command not found

When I run make I (obviously) get missing headers and linkage problems.  I
am using a fresh Mandrake 7.2 installation.  I have got the gnome-*-devel,
gtk+-*-devel and glib-*-devel packages installed.  I think I'm just missing
the macros but I'm not sure.  Could anyone help me out?  If I have hit the
wrong list, please forgive me and point me in the right place.  I'd really
appreciate it.  

Thanks in advance. 


"It's easier to ask forgiveness than it is to seek permission."
  - Rear Admiral Dr. Grace Hopper

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]