Re: Problems writing (tgauge) panel applet

In <20020723151224 GA3601 realh co uk>, I wrote:

> I'm trying to write a panel applet to display a graphical CPU
> temperature gauge, using lm-sensors. If I run it from a terminal, or
> from "Run..." in the GNOME menu, it works normally, but if I quit it,
> then select Reload from the box that appears, it doesn't reload, but a
> little icon appears instead, and there appears to be no process
> associated with it. I think the icon is gnome-unknown.xpm on a black
> background, at half size or less.
> If I restart Gnome, the same thing happens, I just get the unknown icon
> and no process. If I start it from the Add to panel menu, I get the
> unknown icon, but the applet starts too and works normally (it looks
> like the unknown icon appears first because it appears to the left of
> the working applet), and I can remove the unknown icon.

I'm still stuck with this, I've been playing with it a bit more. I've
double-checked to make sure what I've written is similar to the example
at <>. I even cut &
pasted the files from the example to make a test program, and that had
the same problem. Are those docs out of date?

I mainly use Debian unstable (hasn't been updated for a few weeks
though) with Gnome 1, but I've also tested on Red Hat 7.2, and I have
the same problem with both. I've tried downloading a couple of other
simple looking applets, but they had extra goad stuff etc which isn't
covered in the docs above.

So now I've tarted up the makefile a little bit (including a make
uninstall FWIW) and tweaked it so the program can run without
lm-sensors, because I'm hoping someone might be kind enough to download
it and work out what I'm doing wrong. Pretty please :-). Or am I asking
in the wrong place? I couldn't find a mailing list which looked more
suitable for applet development.

The URL is <>.

TH *

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]