Re: Feature request regarding --g-fatals-warnings



Tim Janik <timj@gtk.org> writes:

> > > note, that in many cases, successive warnings/criticals are
> > > produced due to the first one failing, so often, if you don't
> > > fix the first one, you get tons of bogus successors.
> > 
> > Well, I'm currently debugging gnome-libs 2.0 and every time I
> > start a program I get this "you are using the devel branch of GTK+"
> > warning and a couple more "foo() is deprecated" ones.
> 
> that's highly annoying i admit. we had that problem earlier for the canvas,
> i had to s/g_warning/g_message/ on my own there. g_warning() is really
> an inappropriate log-level for that, use g_message("WARNING:") instead if
> you want to shout ;)
> if you provide s/g_warning/g_message/ patches for such things in gtk,
> i'll accept them in a second.

nonononoono.

If you want to change them to simply g_message(), that might
be OK. but replcaing g_warning() with g_message("WARNING:")
is obvious brain-damage. 

If we don't want to trap warnings, then we should add
--g-fatal-criticals. or --g-fatal-warnings=level.

If warnings are meant to be trapped, then you should  
change not-useful-to-trap warnings to g_message().

(And deprecated function warnings can be somewhat useful to trap, if
you don't know where they are coming from.)

Regards,
                                        Owen





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]