Re: [PATCH] glib-1.2.10 compiled on QNX Neutrino



Pavel Roskin <proski gnu org> writes:

> Hello!
> 
> I have successfully compiled glib-1.2.10 on QNX Neutrino. Unfortunately,
> two things had to be done hand.
> 
> I had to replace config.guess and config.sub with the newer versions,
> since the included ones were unable to recognize the OS. It's recommended
> that every package using those files updates them from
> ftp://ftp.gnu.org/gnu/config/ when a new version is released, so please
> don't forget it when you release 1.2.11.

File a bug on bugzilla.gnome.org and I won't forget it.
 
> The other problem is a wrong test for `fd_set' in configure.in. It tests
> for `fd_set' in sys/types.h and then it tests for `fd_mask' (not `fd_set')
> in sys/select.h. QNX Neutrino has `fd_set', but not `fd_mask'. The test
> fails and NO_FD_SET appears in config.h.
> 
> The code doesn't compile with NO_FD_SET, but it compiles perfectly if I
> remove NO_FD_SET from config.h.
> 
> I have made a patch that replaces two checks with one. It is not important
> where fd_set is defined, so it's better to include both headers if they
> are available. It should be the safest thing possible, since some systems
> may require including sys/types.h before sys/select.h, and this is what
> the actual glib code is doing.
> 
> There is no need to define HAVE_SYS_SELECT_H one more time.
> 
> ChangeLog:
> 	* configure.in: Include both sys/types.h and sys/select.h
> 	while checking for fd_set. Don't check for fd_mask.

Seems to have been fixed in GTK+-1.3.x, quite some time ago:

1999-03-14  Raja R Harinath  <harinath cs umn edu>

	* configure.in (glibconfig.h): Remove widechar tests and defines.
	(fd_set): Change the grep for `fd_mask' to search for `fd_set'.
	* gerror.c (fd_mask): Remove conditional typedef.  It is not used
	elsewhere in the file.
	* gmain.c (fd_mask): Likewise.

Though this change is simpler - just s/fd_mask/fd_set/ in the configure.in
(Does that work for you?)

Again, if you file a bug, I'll remember to backport this for 1.2.11
(if/when that happens), otherwise I won't.

Thanks,
                                        Owen




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]