Re: GConf problems

   I did make a small test program. See the attachment. 

   I think the problem is related to some threads -- maybe some
deadlock. You can see in the backtrace below, that the program halts in a
pthread_mutex_lock.  Also, the deadlock only happens sometimes.  

   Could it be that I made a mistake? Should I call gdk_threads_enter
before unref'ing  the GConfClient object? 

On 18 Apr 2000, Havoc Pennington wrote:

> Gustavo Joćo Alves Marques Carneiro <> writes:
> >   Hi.  I'm trying to use GConf.  It seems to be working well except when
> > my program tries to destroy de GConfClient object.  Then, the program
> > halts with the message:
> > 
> > 	Trying dir /home/ee96090/opt/gnome//share/oaf
> > 
> >   (/home/ee96090/opt/gnome/ is the prefix where it (and all gnome) is
> > installed)
> > 
> >   When I run gconfd& in background before running my program, this doesn't
> > happen.  Also, I run gconfd& instead of gconfd because sometimes gconfd
> > doesn't exit -- it hangs.
> > 
> >   Can anyone help me? Thanks!
> > 
> Can you send me a small test program? I think it's an OAF bug, but I
> can't be sure without a test case.
> Havoc

#0  0x4046c2f4 in   ()
#1  0x404908ec in svc_fdset ()
#2  0x403efe9f in pthread_mutex_lock ()
#3  0x402630d7 in gdk_event_prepare (source_data=0x0,
    timeout=0xbfffdee4, user_data=0x0) at gdkevents.c:2066
#4  0x4039e758 in g_main_iterate (block=1, dispatch=1) at gmain.c:771
#5  0x4039ec11 in g_main_run (loop=0x8088890) at gmain.c:935
#6  0x404a9c7d in oaf_server_by_forking (cmd=0x404ad440, ior_fd=123, 
    ev=0xbfffea4c) at oaf-registration.c:301
#7  0x404a81c5 in local_activator (regcat=0xbfffea7c, cmd=0x404ad440, 
    ior_fd=123, ev=0xbfffea4c) at oaf-mainloop.c:255
#8  0x404aa0b8 in oaf_activators_use (regcat=0xbfffea7c, cmd=0x404ad440, 
    ior_fd=123, ev=0xbfffea4c) at oaf-registration.c:464
#9  0x404aa207 in oaf_service_get (regcat=0xbfffea7c) at
#10 0x404a7fa1 in oaf_activation_context_get () at oaf-mainloop.c:137
#11 0x404a9545 in oaf_activate_from_id (
    aid=0x403dc288 "OAFAID:[OAFIID:gconfd:19991118]", flags=4,
    ev=0xbfffeaf4) at oaf-activate.c:122
#12 0x403c77b1 in try_to_contact_server (start_if_not_found=0, err=0x0)
    at gconf.c:1438
#13 0x403c7911 in gconf_get_config_server (start_if_not_found=0, err=0x0)
    at gconf.c:1488
#14 0x403c5999 in gconf_engine_unref (conf=0x80701f0) at gconf.c:314

Gustavo J. A. M. Carneiro


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]