Re: gnome-libs and DB3

Matthew Schalit wrote:
> Drazen Kacar wrote:

> > nm /usr/local/lib/ | grep __db185_open
> > 
> > [2509]  |     64740|    1596|FUNC |GLOB |0    |7      |__db185_open
> > 
> > I suppose that original poster just didn't pass --enable-compat185 to
> > configure script and that's all.
> Well you found it on yours.  That was cool.  Unfortunately, during a few 
> weeks of working on this with Sleepycat, I could never get __db185_open
> to exist in my compile, even if I used --enable-compat185.  I'm running
> i586-sco-sysv5uw7.1.1.

I've never worked on UnixWare, so I can't offer any advice, I'm afraid.
But weeks?

> I tried both 3.1.17 and 3.2.3h from  Neither built the __db185_open
> function when I used --enable-compat185.

My version is 3.2.9 on Solaris. You could try with that version, if you
want to give it another shot. If you encounter problems, mail me. Blind
debugging is fun sometimes.

> My suggestion is to use the 2.7.7 like the readme says.

It might be that there are conversion issues. If you've first built
gnome-libs with version 2 and then decided to migrate to version 3, it
might be hard/impossible/whatever to upgrade the data files. But this is
just a wild guess.

 .-.   .-.    Sarcasm is just one more service we offer.
(_  \ /  _)
     |        dave arsdigita com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]