Re: gnome-libs and DB3

Drazen Kacar wrote:
> Matthew Schalit wrote:
> > Drazen Kacar wrote:
> > > nm /usr/local/lib/ | grep __db185_open
> > >
> > > [2509]  |     64740|    1596|FUNC |GLOB |0    |7      |__db185_open
> > >
> > > I suppose that original poster just didn't pass --enable-compat185 to
> > > configure script and that's all.
> >
> > Well you found it on yours.  That was cool.  Unfortunately, during a few
> > weeks of working on this with Sleepycat, I could never get __db185_open
> > to exist in my compile, even if I used --enable-compat185.  I'm running
> > i586-sco-sysv5uw7.1.1.
> I've never worked on UnixWare, so I can't offer any advice, I'm afraid.
> But weeks?

Hi Dave,

To build Gnome, I had to compile about 50 different apps and libraries.
Because there were so many parts to the foundatation that could fail, I
refused to move onto the next app if I couldn't get the last one to test
successfully.  I have a long running bug-report into gcc about --with-gnu-as,
and have problems with tcl/tk-8.3.2 not supporting threads in addition to
some issues with autoconf and gnu-m4.  All these parts are used to create BDB
and test it in tclsh.  It took weeks of work with sleepycat and others
to get all these parts aligned, and I'm no slouch, being the author of
the UnixWare 7 FAQ and various mini-HOWTOs.

> > I tried both 3.1.17 and 3.2.3h from  Neither built the __db185_open
> > function when I used --enable-compat185.
> My version is 3.2.9 on Solaris. You could try with that version, if you
> want to give it another shot. If you encounter problems, mail me. Blind
> debugging is fun sometimes.

Ok.  Apparently they released a new version since I built mine in February.
Let's give that one a try right now....

Ok.  I tried 3.2.9 and I can get it to ouput a __db185_open like you mentioned.

Given that fact, it appears that it would pass the current gnome-libs configure 
conftest.  I don't know whether it would work in practice though, because, as 
I mentioned, any version above 2.7.7 breaks db185 compatability due to the removal 
of functions like dbopen().  

In addition, I couldn't run the testsuite on this version even if I used the 
trick that I needed to use to make the testsuite run on 3.1.17, namely, I needed 
to use my and ltconfig from my libtool-1.3.5 distro rather than the 
ones BDB included.   No luck there.  I get a dynamic linker error complaining
symbol not found: cond_signal; referenced from: .libs/

So if I can't test 3.2.9 and the readme says to use 2.7.7, then I figure
it's best for me to use 2.7.7.

Take it easy,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]