Re: Problems with loading gdk-pixbuf

Presumably all the loader modules are linked against shared versions
of the respective graphics libraries?  At least on Solaris, this
caused similar problems, when linked against the static graphics


> On Wed, 01 Dec 1999, Federico Mena Quintero wrote:
> > >  I've checked out both gdk-pixbuf and eog from CVS yesterday. Compiled
> > >  and installed gdk-pixbuf with prefix /usr. Then compiled eog. Tried to
> > >  open an image with it and it said 'Unable to load
> > >  no such file'. I checked and that file is in
> > >  /usr/lib/gdk-pixbuf/loaders. Are there any configurations settings I
> > >  need to change in order for that file to be loaded?
> > 
> > Could you please trace the program starting when it tries to load the
> > image and see why dlopen() fails?
> I traced it through it and it fails in _g_module_open(). The path to the
> file is the correct one.
> What's weird is that I did make clean, then make install again and now
> it's working...
> But, similar problem occurs. When I run eog I get copious errors:
> Gtk-WARNING **: Unable to locate loadable module in module_path: ""
> What could be the source of that?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]