Re: SIGSEGV's in gnomecc-1.2.2

Matt Schalit wrote:
> Hi folks,
> I get SIGSEGV's when I try to run gnomecc-1.2.2 using
> enlightenment-0.16.5 on i586-sco-sysv5uw7.1.1, and I
> never see the control center.
> Though gnomecc doesn't show up, I do see a popup window
> with the SIGSEGV error message and the process number.
> I'm currently trying to compile gdb, hoping that someone
> can tell me how to rightly use it to get you an output, but
> gdb-5.0 had 224 unexpected testsuite failures, so I'm not sure that
> I want to unleash it.  Please advise.

Here's the trace...

I poked around the mail archives and tired gdb regardless of
it's testuite failures.  Here's what I did and what I saw:
I ran gdb.  Then I told it path and filename to gnomecc,
then I ran it with 'run' and traced it with 'bt'.

  $ gdb
(gdb) file /usr/local/bin/gnomecc
Reading symbols from /usr/local/bin/gnomecc...done.
(gdb) run
Starting program: /usr/local/bin/gnomecc
warning: Lowest section in /usr/lib/ is .hash at 00000094
[New LWP 1]
[New LWP 2]

Program received signal SIGSEGV, Segmentation fault.
0xbfa6f929 in _Xwcslen () from /usr/lib/
[New Thread 1]
(gdb) bt
#0  0xbfa6f929 in _Xwcslen () from /usr/lib/
#1  0x400 in ?? ()
#2  0xbfa6fa28 in _XwcTextListToTextProperty () from /usr/lib/
#3  0xbfb9048b in gtk_label_parse_uline (label=0x8139180,
    string=0xc615 <Address 0xc615 out of bounds>) at gtklabel.c:1005
#4  0xbfd95397 in create_label (label_text=0xbfe0a339 "", keyval=0x8047878)
    at gnome-app-helper.c:402
#5  0xbfd9630e in create_menu_item (menu_shell=0x8137ed0, uiinfo=0x809c770,
    is_radio=0, radio_group=0x81379f8, uibdata=0x8047988,
    accel_group=0x812ea40, uline_accels=1, pos=134510536)
    at gnome-app-helper.c:933
#6  0xbfd96f1a in gnome_app_fill_menu_custom (menu_shell=0x8137ed0,
    uiinfo=0x809c770, uibdata=0x8047988, accel_group=0x812ea40,
    uline_accels=1, pos=1) at gnome-app-helper.c:1326
#7  0xbfd96fa9 in gnome_app_fill_menu_custom (menu_shell=0x812bd28,
    uiinfo=0x809c84c, uibdata=0x8047988, accel_group=0x812ea40,
    uline_accels=1, pos=1) at gnome-app-helper.c:1341
#8  0xbfd976a1 in gnome_app_create_menus_custom (app=0x812db90,
    uiinfo=0x809c820, uibdata=0x8047988) at gnome-app-helper.c:1516
#9  0xbfd97163 in gnome_app_create_menus (app=0x812db90, uiinfo=0x809c820)
    at gnome-app-helper.c:1395
#10 0x804e967 in create_window () at main.c:200
#11 0x804ecf8 in main (argc=1, argv=0x8047a0c) at main.c:282

Does this help at all?
Thanks for you time,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]