ORBit-0.4.90 problem


I tried the new version of ORBit-0.4.90 by uninstalling ORBit-0.4.3
(make uninstall) and compiled and installed the new version. Started X and
the gnome-name-service was not working correctly. I receive this message

** WARNING **: Could not get name service!

** ERROR **: file goad.c: line 606 (real_goad_server_activate): assertion
failed: (name_service != CORBA_OBJECT_NIL)

on text console and my desktop panel applets were screwed up. After the
error message and after gnome started gnome-name-service was running. Only
the first things using gnome-name-service didn't found it. That is why the
panel applets where screwed up.

When I call gnome-session to startup gnome and when some application
started by gnome-session requires gnome-name-service it starts
automatically but with the new version of ORBit it doesn't. I tried to
compile again gnome-libs-1.0.10 and gnome-core-1.0.7 with the new version
and that didn't solve the problem.

I did a little search on sources of everything installed related to gnome
and I found on gnome-libs-1.0.10, libgnorba source, file orbitns.c the
function gnome_name_service_get. I think the the new ORBit version has the
timeouts of the remote calls changed or something like that and doesn't
give enough time to start gnome-name-service before it says that it
isn't available.

I also noted a new file called old-name-service on the new version of
ORBit. Maybe gnome-name-service needs some modifications.

                                               Bruno Pires Marinho

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]